VirtualBox

Ticket #5702 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Windows 7(x64) Guest Stops Responding (3.1.0 regression) -> check with 3.1.2

Reported by: Decept1k0n Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I just upgraded to VirtualBox 3.1.0 from the previous release, recently at random intervals my Windows 7(x64) guest machine will just freeze and become un-responsive to mouse or keyboard input. The problem recently started happening after the upgrade to the newest VirtualBox release and never happened before.

Sometimes, I'm able to go for a few hours without the guest freezing and other times it will run for a few minutes and then freeze. When the freeze happens, all activity just seems to come to a halt in the guest machine.

The machine I'm running VirtualBox on is a 17" Unibody Macbook Pro(2.66GHz, 8GB SDRAM, 500GB HDD) using Snow Leopard 10.6.2.

Attachments

VBox.log Download (45.4 KB) - added by Decept1k0n 4 years ago.

Change History

Changed 4 years ago by Decept1k0n

comment:1 Changed 4 years ago by jfzed

I have the exact same problem;

Environment: MBP Mac OS X 10.6.2 VB 3.1.0 guest MS Windows 7 64-bit

Problem began when upgrade to 3.1.0; I've tried to go back to 3.0.12 but it does not work.

It may run for few hours or it freezes as soon as any window or program is invoked; Activity Monitor shows VB at 199%; CPU loop 100% x 2 CPUs

Please address this problem since now I have an unusable MS Windows 7 environment which has material I need for my work.

N.B. An Ubuntu 64-bit guest instance runs fine on VB 3.1.0; the problem occurs only with MS Windows 7 64-bit

jfzed

comment:2 Changed 4 years ago by frank

  • Summary changed from Windows 7(x64) Guest Stops Responding to Windows 7(x64) Guest Stops Responding (3.1.0 regression)

comment:3 Changed 4 years ago by sandervl73

  • Summary changed from Windows 7(x64) Guest Stops Responding (3.1.0 regression) to Windows 7(x64) Guest Stops Responding (3.1.0 regression) -> check with 3.1.4

Quite likely fixed in the upcoming 3.1.4 as you're using 2 CPUs in the guest.

comment:4 follow-ups: ↓ 5 ↓ 6 ↓ 7 ↓ 8 Changed 4 years ago by frank

  • Summary changed from Windows 7(x64) Guest Stops Responding (3.1.0 regression) -> check with 3.1.4 to Windows 7(x64) Guest Stops Responding (3.1.0 regression) -> check with 3.1.2

comment:5 in reply to: ↑ 4 Changed 4 years ago by jfzed

Replying to frank:

yes, I am using 2 x CPUs in the guest configuration

jfzed

comment:6 in reply to: ↑ 4 Changed 4 years ago by jfzed

Replying to frank:

given your comment, I have configured the guest, W7 64-bit, to 1 x CPU; it is working fine and has not crashed, not yet; report back if it does.

Ubuntu 9.10 64-bit was also configured with 2 x CPUs; it does work fine.

jfzed

comment:7 in reply to: ↑ 4 Changed 4 years ago by Decept1k0n

Replying to frank:

I too have tested W7(x64) with 1 CPU configuration and am able to run without any freezing or unusual behavior as when running with 2 CPUs.

As a side note, how would I go about getting a copy of 3.1.2/3.1.4 to test with the 2 CPU configuration? I see no way to download those builds from the main page unless I do it using the subversion builds for the OSE version.

comment:8 in reply to: ↑ 4 Changed 4 years ago by jfzed

Replying to frank:

I had the same freeze problem with an Ubuntu 9.10 64-bit which is configured with 2 x CPUs. Previously I had experienced the problem on W7 64-bit only.

I have changed the Ubunto 64-bit guest to 1 x CPU and will report should it freeze also;

comment:9 Changed 3 years ago by frank

Still relevant with VBox 3.2.10?

comment:10 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use