VirtualBox

Ticket #5631 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

Windows guests don't follow symlinks on shared folders -> Fixed in SVN/3.1.4

Reported by: sorcerer Owned by:
Component: shared folders Version: VirtualBox 3.1.0
Keywords: symlink Cc:
Guest type: Windows Host type: Linux

Description

With VirtualBox 3.1.0 Windows XP guests don't follow symlinks in shared folders if hostmachine is Linux. Windows think that the symlinks is regular files.

Attachments

symlinks.patch Download (522 bytes) - added by sorcerer 10 years ago.
Fix for VirtualBox 3.1.0_OSE
symlinks.2.patch Download (537 bytes) - added by sorcerer 10 years ago.
Patch fixes incorrect memory usage (corrected)
13hours.html Download (63 bytes) - added by hoprutop 9 years ago.

Change History

comment:1 Changed 10 years ago by sorcerer

I use the latest Ubuntu 9.10 on amd64 and VirtualBox build from the corresponding virtualbox.org repository.

comment:2 Changed 10 years ago by krystian

I have the same behavior with an OS X (10.6.2) host and a Windows XP SP3 guest.

comment:3 in reply to: ↑ description Changed 10 years ago by micsa

I can confirm this bug, I'm using Linux 64-bit host and WinXP guest. The symlinks to directories in the shared folders are treated as files, but entering them is possible only explicitly with "cd folder" command.

comment:4 Changed 10 years ago by alphazo

Confirmed on ArchLinux 32-bit (last update done on Dec 02) host and Windows XP SP3 guest.

comment:5 Changed 10 years ago by herberth

Confirmed on Ubuntu 9.04, 32-bit host and winXP guest.

comment:6 Changed 10 years ago by sigdrifa

I can confirm this as well on Ubuntu 9.10 64 bit host. However, the problem is not unique to Windows guests. I have an Ubuntu 9.10 and a Linux Mint (both 32bit) guest with the same problem. And unlike micsa, I can't cd into them from the command line in either of the Linux guests.

comment:7 follow-up: ↓ 8 Changed 10 years ago by ralf

I can confirm this regression with VirtualBox 3.1 on Kubuntu 9.10 (32bit) and with a Windows XP SP3 (32bit) guest.

For Linux guests, the issue seems to be different - symlinks in Shared folders are not at all supported:  http://www.virtualbox.org/ticket/818 . But unlike this problem, that is not a regression.

comment:8 in reply to: ↑ 7 Changed 10 years ago by sigdrifa

Replying to ralf:

For Linux guests, the issue seems to be different - symlinks in Shared folders are not at all supported:  http://www.virtualbox.org/ticket/818 .

It used to work before I upgraded to 3.1.0, though.

comment:9 Changed 10 years ago by ralf

Ah, ok... the other bug is invalid or at least not completely up-to-date then. Sorry.

comment:10 Changed 10 years ago by me999

Confirmed with VirtualBox 3.1.0 r55467, Fedora 12 host (32-bit) and Windows Vista SP2 guest (32-bit). I have a symbolic link in a shared folder that points to a directory outside of the shared folder. In the guest system, it appears as a file that cannot be opened. cd'ing to the link/file in the command prompt does work however. This problem did not occur before upgrade to 3.1.

Changed 10 years ago by sorcerer

Fix for VirtualBox 3.1.0_OSE

comment:11 Changed 10 years ago by sorcerer

Please see my fix of the bug for OSE.

comment:12 Changed 10 years ago by sorcerer

Note that this patch won't work correctly with symlinks to non-directories.

Changed 10 years ago by sorcerer

Patch fixes incorrect memory usage (corrected)

comment:13 Changed 10 years ago by sorcerer

Use symlinks.2.patch instead of symlinks.patch. The second patch works correctly with symlinks to all file types.

comment:14 Changed 10 years ago by davenz

I see the same thing on an Opensolaris snv_128a x64 host, but using Ubuntu 9.04 and 9.10 guests - I confirm this isn't confined to Windows guests as another poster has advised.

comment:15 Changed 10 years ago by sunlover

  • Summary changed from Windows guests don't follow symlinks on shared folders to Windows guests don't follow symlinks on shared folders -> Fixed in SVN

The problem already fixed in SVN, see  http://www.virtualbox.org/changeset/25292 The fix will be available in the next maintenance release (3.1.2).

comment:16 Changed 10 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:17 Changed 9 years ago by frank

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Summary changed from Windows guests don't follow symlinks on shared folders -> Fixed in SVN to Windows guests don't follow symlinks on shared folders -> Fixed in SVN/3.1.4

comment:18 Changed 9 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Changed 9 years ago by hoprutop

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use