VirtualBox

Ticket #560 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Guest additions and GdiPlus.dll

Reported by: moonlight Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords: Guest Additions
Cc: Guest type: other
Host type: other

Description

VBox: 1.4.1_OSEr4087 Guest: Win2003Server Guest Additions for 1.4.1

MS Visual Studio and some other .net applications crash with access violation in gdiplus.dll (If guest additions are not installed applications work ok)

P.S. Is source code available for additions?

Change History

comment:1 Changed 7 years ago by sandervl73

They are included in SVN. Where did you get the guest additions from?

Can you tell in more detail how exactly to reproduce the crash? Best would be to include a simple .net application that we could use for testing. Thanks.

comment:2 Changed 7 years ago by moonlight

Additions were from  http://virtualbox.org/download/

With simple application it appeared hard enough to reproduce problem. Easiest way is to reproduce on Visual Studio 2005 - it's usually enough to create empty WinForms application - studio will crash.

How to build additions from svn and where exactly the are?

comment:3 Changed 7 years ago by sandervl73

Wait a few days for 1.5.0. It's possible your problem is fixed in there. We've added DirectDraw support and I recently fixed a gdiplus related bug.

comment:4 Changed 7 years ago by moonlight

Issue seems to be fixed in 1.5.0 Thanks!

comment:5 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use