VirtualBox

Ticket #558 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

The vboxvideo driver causes the mouse pointer to disappear

Reported by: grahamt Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords: ubuntu vboxvideo missing mouse pointer
Cc: Guest type: other
Host type: other

Description

I am using VirtualBox 1.4.0 under WindowsXP Pro 2002 with SP2. I have installed Ubuntu Linux 7.04 and as installed it is runs at the highest screen resolution of 1024x768. However, my laptop is an Acer Travelmate with a 15.4” widescreen and I am running it at the highest supported screen resolution of 1680x1050. On this the VirtualBox window looks very small. I wanted to run it at a higher resolution of either 1152x864 or 1280x1024.

I have followed the advice in a number of posts on this forum by bodhi.zazen and have successfully completed the following steps:

1) With Ubuntu running and logged in I clicked on Devices > Install Guest Additions... (This successfully mounted the Additions ISO image on the Ubuntu Desktop).

2) Open a Terminal window in Ubuntu

3) Execute the following command:

sudo aptitude install build-essential kernel-header-uname -r

(As noted in the relevant post, the ` is the backtic symbol found on the key just to the left of the “1” key on most keyboards). Executing this command requires you to enter the Adminstrator password, which will normally be your normal login password. Ubuntu sets the root password to yours by default.

4) Execute the following command:

sudo sh /media/cdrom0/VBoxLinuxAdditions.run all

(At this point you will have to reboot).

5) Once Ubuntu is up and running again, execute the following command in a Terminal window:

sudo dpkg-reconfigure -phigh xserver-xorg

(This will start a “graphical” reconfiguration session. “OK” the first option, the type of display driver, vesa is the default, and then on the next option, desired screen resolutions, select the additional ones over and above the defaults of 640x480, 800x600 and 1024x768. I added 1152x864 and 1280x1024). “OK” this new configuration. Once again you need to reboot).

All of these operations appear to have worked successfully. I opened xorg.conf in a text editor and it does appear to have added the additional screen resolutions to the definitions.

However, despite all this, when I went in Ubuntu to System > Preferences > Screen Resolution, the only options offered to me remained 640x480, 800x600and 1024x768.

I then ran Step 5) again and by chance noticed that there was an option of a display device of vboxvideo. When I accepted this device I discovered that on rebooting Ubuntu I now had the missing resolutions. The window assumed the size of the highest available default resolution.

However, now the mouse pointer disappeared from the screen as soon as I clicked within the window. It would only reappear once I had released it with the Host key. As soon as I clicked in the window it disappeared again. However, although the mouse pointer was not visible it clearly was acting within the session window since by moving the mouse around, it was possible to see all of the functions highlighted as the mouse pointer location passed over them.

By hunting around with the mouse and by using the keyboard shortcuts I managed to find System > Preferences > Screen Resolution and changed the resolution back to 1024x768 as it was with the vesa driver, where everything worked. However, the mouse pointer still wouldn't appear. I even set 1024x768 as the default and rebooted but still no mouse pointer. I tried this both in fullscreen mode and windowed mode but it made no difference.

It was only after I had run Step 5) again and changed the driver back to vesa that the mouse pointer again became visible.

The conclusion can only be that there is a bug in the vboxvideo driver that is causing the mouse pointer to disappear, whatever the screen resolution chosen.

Change History

comment:1 Changed 7 years ago by michael

grahamt: it sounds to me like you are using the X.Org mouse driver - look for a line like

Driver "mouse"

  • instead of the VirtualBox one, which should be

Driver "vboxmouse"

Please try this out and let me know if it solves your problem.

comment:2 Changed 7 years ago by grahamt

Michael, thanks for your prompt reply and guidance. I'll check that out tonight. Do you know if there is a parameter of the dpkg-reconfigure command, like -phigh for video changes, that will enable the part of the application that applies only to the mouse?

comment:3 Changed 7 years ago by michael

I would have to check. There might be a "vboxmouse" option for the mouse driver though.

comment:4 Changed 7 years ago by grahamt

Michael, you are absolutely correct, the Mouse Device was shown as "mouse", not "vboxmouse", in xorg.conf. The strange thing is that after installing the Guest Additions, xorg.conf had both "vboxmouse" and "vboxvideo" in the respective Devices section.

It would appear that the bug is actually in dpkg-reconfigure. The evidence is that running it with the -phigh switch correctly enables the additional screen resolutions to be set but also, by default, resets the Mouse Device back from "vboxmouse" to "mouse", as it was before installing the Guest Additions. I did realise that you had to select the "vboxvideo" device as well because it presents "vesa" but there is no indication that it also changes the Mouse Device.

Running dpkg-reconfigure without the -phigh switch enables you to run through the entire configuration process but at no point does it offer you an option to set the Mouse Device!

In the end I solved the problem by running the dpkg-reconfigure -phigh xserver-xorg command to set up the Video Driver as "vboxvideo" and select the desired additional screen resolutions and then separately edited the xorg.conf file to put the Mouse Device back to "vboxmouse" as it should have been.

Of course, I could have done all the editing manually. It's just a great pity that dpkg-reconfigure doesn't behave itself!

comment:5 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

You might say that it is the additions installer which isn't behaving itself, by making changes behind dpkg-reconfigure's (or rather, debconf's) back, when debconf expects to be the only one making changes. Unfortunately, I still haven't found a way to tell debconf to change just those two settings - that would be much better than what we are doing now. (Or perhaps we should just run dpkg-reconfigure or whatever with instructions to the user about what to change?).

Anyway, I will close this bug. If you do find a way to make those changes through debconf without requiring the user to change things manually, feel free to add a comment to the bug anyway.

comment:6 Changed 7 years ago by grahamt

  • Status changed from closed to reopened
  • Resolution invalid deleted

Well yes, I take your point. If debconf is changing xorg.conf based on what it thinks ought to be there rather than on what it actually finds then I can understand the outcome. I assume that debconf is just doing what it thinks is right.

However, a little lateral thinking presents the perfect solution. You run dpkg-reconfigure to select your desired additional screen resolutions BEFORE you install the Guest Additions. I've just tried that and it works exactly as it should. I now have an xorg.conf that contains the extra screen resolutions AND the correct Devices, without having to resort to manually editing xorg.conf.

I've reopened this so that it comes to your attention but please feel free to close it again.

comment:7 Changed 6 years ago by orestes

I'd like to inform that this issue is still present today (january 2008), and ISN'T resolved by configuring "vboxmouse" driver in xorg.conf

Situation:

  • Host: Kubuntu Gutsy
  • Guest: Kubuntu Hardy alpha 2 (installed to test new features, specially kde4)
  • VirtualBox Guest Additions installed

If my guest xorg.conf uses the "vboxmouse" driver for mouse and "vboxvideo" driver for video, no mouse pointer is shown. When using "vesa" as video driver the mouse pointer is shown correctly, but the max. possible resolution is only 800x600.

comment:8 follow-up: ↓ 10 Changed 6 years ago by michael

Confirmed. The guest additions installer did not cope correctly with the X.Org config file with comes with Kubuntu 8.04a2. As a quick fix, add an

Option "CorePointer"

line below

Driver "vboxmouse"

The next release will deal with this correctly.

comment:9 follow-up: ↓ 11 Changed 6 years ago by Steck

I can confirm that this problem also exists in Ubuntu Gutsy (gnome). VirtualBox guest additions were installed and I lost the visibility of my mouse.

Host: Ubuntu Gutsy Guest: Ubuntu Hardy Alpha2; Kubuntu Hardy Alpha2

comment:10 in reply to: ↑ 8 Changed 6 years ago by orestes

Many thanks. This fix worked for me.

comment:11 in reply to: ↑ 9 ; follow-up: ↓ 12 Changed 6 years ago by michael

Replying to Steck:

I can confirm that this problem also exists in Ubuntu Gutsy (gnome). VirtualBox guest additions were installed and I lost the visibility of my mouse.

Host: Ubuntu Gutsy Guest: Ubuntu Hardy Alpha2; Kubuntu Hardy Alpha2

Just to be clear - the quick fix described in comment 8 above applies to the xorg.conf file inside the guest. This is a problem of the guest additions (more precisely their installer script) and the host system should not be relevant.

comment:12 in reply to: ↑ 11 Changed 6 years ago by Steck

Replying to michael:

Just to be clear - the quick fix described in comment 8 above applies to the xorg.conf file inside the guest. This is a problem of the guest additions (more precisely their installer script) and the host system should not be relevant.

Okay, thanks for clearing that up. In your earlier comment, I was unclear if "The next release will deal with this correctly" referred to the host (VBox Software), or the guest (being alpha). I'll use your quick fix above as a temporary solution. Many thanks!

comment:13 Changed 6 years ago by michael

The next release of VirtualBox (and the Guest Additions) will fix the problem. However, since the fix in the next version merely consists of applying the "quick fix" automatically you are not missing anything.

comment:14 Changed 6 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

The fix is contained in 1.5.6, closing.

comment:15 Changed 6 years ago by michael

To be more precise, 1.5.6 fixes the problem for Kubuntu (Ubuntu?) 8.04, and 1.6.0 contains a more general fix which should stop this appearing again.

comment:16 Changed 6 years ago by grahamperrin

Please:

  • how best to work around or resolve the issue on Mac OS X?

There's plenty of discussion in the forums but some is contradictory, so a bullet point summary will be greatly appreciated.

1.5.6 not available

For Mac OS X the most recent is VirtualBox-osx-1.5.51-r27946-beta3.dmg

The Mac OS X port is not yet completed

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use