VirtualBox

Ticket #5564 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Crash in seemless mode while doing a software compile

Reported by: acmyau Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I've listed 'Component' as other as I'm not sure which specific component is involved. I'm running 3.0.12 (AMD64 build) on Mandriva 2009.1 64bit, running a 32bit Windows XP guest.

I recently needed to kick off a compile of my company's software (haven't had to for some time), and find that about 2/3rds of the way through VirtualBox crashed - the log showed a GURU_MEDITATION message. At this time I was running 3.0.8.

I restarted, tried again, and got a crash again, though in a different spot. I decided then to upgrade this morning to 3.0.12 just in case there was something there related (changelog didn't show anything obvious) - but trying the build again resulted in another crash.

In all the above tests my guest was running in seamless mode.

For some strange reason I decided to switch out of seamless mode and try it. So after a restart of the guest (seamless doesn't go in and out smoothly on my system - but that's another issue) I kicked of the build again.

Now it's working - the build completes without crashing. So I don't know why seamless would make a difference - or if something else in the environment has magically changed and seamless is a red herring.

I've attached: VBox-crash-3.0.8.log - which is the log from the first crash in 3.0.8 VBox-crash-3.0.12.log - which is the log from the crash in my first attempt in 3.0.12

Attachments

VBox-crash-3.0.8.log Download (292.7 KB) - added by acmyau 4 years ago.
Log from 3.0.8 crash
VBox-crash-3.0.12.log Download (268.9 KB) - added by acmyau 4 years ago.
Log from 3.0.12 crash

Change History

Changed 4 years ago by acmyau

Log from 3.0.8 crash

Changed 4 years ago by acmyau

Log from 3.0.12 crash

comment:1 Changed 4 years ago by sandervl73

  • Cc tony.young@… removed
  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate. You can work around it for now by turning on VT-x in your BIOS and in the VM settings.

comment:2 Changed 4 years ago by acmyau

Fair enough - I couldn't find a ticket that looked like a duplicate, hence I created a new.

Note though that that work around does not work for me. I'm unable to enable VT-x in my BIOS as the BIOS for my system only exposes a VT-d setting (known problem with the vendor, unresolved).

I do however have the work-around I mentioned to switch out of seamless mode.

If you could please let me know which issue I've duplicated I'll track it.

comment:3 Changed 4 years ago by sandervl73

Don't worry about it. It's hard to find the duplicate unless you're a VBox developer. :) It's #5253.

Turning on VT-d doesn't turn on VT-x as well?

comment:4 Changed 4 years ago by acmyau

No unfortunately - I tried when I was attempted to enable SMP in the guest ;) Thanks

comment:5 Changed 4 years ago by sandervl73

Apparently there are two versions of your CPU; one with and one without VT-x. ( http://en.wikipedia.org/wiki/Yorkfield_(microprocessor)#Yorkfield-6M)

comment:6 Changed 4 years ago by acmyau

Interesting - thanks for that. It's a work system so I don't have much control over what I get - but I'll mention the problem next time.

I don't know if it helps or makes it worse, but I just got another crash in non-seamless mode overnight - so the fact it worked for me yesterday in non-seamless appears to have been a fluke. Guess I just have to try to live with it until you're able to complete a fix. Thanks again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use