VirtualBox

Ticket #5563 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Booting guest CentOS 5.3 x86_64 kernel reboots host

Reported by: sfink Owned by:
Priority: blocker Component: other
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have a 32-bit CentOS 5.3-ish host machine (started as CentOS 5.1, and upgraded from there) in which I installed 64-bit CentOS 5.3 as a guest, using a slightly customized kernel. It works fine.

In order to help someone track down a bug in SystemTap, I exported the VM and imported it into a 32-bit Fedora 10 host OS. When I start up the VM, it runs grub, then soon after the guest kernel starts booting, it reboots the host OS.

I compared the .VirtualBox/Machine/CentOS5.3-x86_64/CentOS5.3-x86_64.xml files between the original VM and the exported-then-imported VM and noticed a number of differences, so I tried using the original XML file with just the machine and disk uuids changed. This time, it froze my host instead of rebooting it. Which at least allowed me to see how far it made it. The last line was of the guest kernel printing out the "initrd..." line followed by a blank line.

My host kernel is:

Linux foxglove.localdomain 2.6.27.38-170.2.113.fc10.i686 #1 SMP Wed Nov 4 17:55:39 EST 2009 i686 i686 i386 GNU/Linux

Attachments

VBox.log Download (42.0 KB) - added by sfink 4 years ago.

Change History

Changed 4 years ago by sfink

comment:1 Changed 4 years ago by Technologov

Since your host kernel is "2.6.27" you definitely running non-standard CentOS/RHEL host.

Can you use standard stock kernel for this test please (2.6.18.el5) ?

One thing that looks strange (and caught my eye) is that you have no NX enabled. Can you try to enable Intel NoeXecute (NX) please in BIOS?

-Technologov

comment:2 Changed 4 years ago by Technologov

A potential duplicate found: #5580

-Technologov

comment:3 Changed 4 years ago by pedrorib

Hi, I have a Lenovo T400 with a P8400 processor (Intel VT enabled).

When I run a x64 guest (Fedora 6 64 bit or RHEL 5 64 bit) on my x32 Linux (Debian testing/squeeze) the OS immediately hangs and I must do a cold boot restart (press the shutdown button for 3 secs).

Bug is reproducible every time. There is not Vbox.log since all data written to disk is lost immediately after a hang and restart.

This happens with both virtualbox-3.0.12 closed source and 3.0.10-OSE included in Debian squeeze.

comment:4 Changed 4 years ago by Technologov

A potential duplicate found: #5263

Please change this bug to "blocker", as it crashes Host.

-Technologov

comment:5 Changed 4 years ago by sfink

Sorry, I haven't had a chance yet to do any further investigation.

I'm not running a CentOS or RHEL host, though -- I'm running a standard Fedora 10 host kernel.

comment:6 Changed 4 years ago by sfink

I don't think I can change it to blocker. At least, I don't see any way to do it in the interface. Do I have TICKET_CHGPROP? Or are you asking someone else to change it?

comment:7 Changed 4 years ago by Technologov

I am asking someone else; VBox developers can.

-Technologov

comment:8 Changed 4 years ago by klaus

  • Priority changed from major to blocker

comment:9 Changed 4 years ago by Technologov

hmmm... I don't fully understand it.

I have several RHEL guests runing happily here on my hosts.

Host1: Mandriva Linux 2010, x64, Core2, VBox 3.2.0

Host2: Windows XP, Core2, VBox 3.2.0

Do you have this problem on 3.2.0 as well?

-Technologov

comment:10 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Actually a duplicate of #6166 and fixed in the next maintenance release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use