VirtualBox

Ticket #5535 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Memory leak when using 3D acceleration

Reported by: MMMartin Owned by:
Priority: critical Component: 3D support
Version: VirtualBox 3.0.12 Keywords: memory leak
Cc: Guest type: other
Host type: other

Description

I found a memory leak in VBox 3.0.12 (it is present in 3.1 beta2 as well) with 3D acceleration enabled. It appears when trying to run MS Visual Studio 2010 beta and in my case it causes the VirtualBox.exe process consuming more than 400MB RAM in about a minute leading to a crash of the process and thus the VM.

To reproduce the problem:
Vista 32bit host, XP SP3 32bit guest, VB 3.0.12
install GA in safe mode
install MS Visual Studio 2010 Ultimate beta
enable 3D acceleration
run MS VS 2010, wait for the main window to appear, watch memory usage of the VirtualBox.exe process

Note: This is the issue I have already described  here and  here.

Log file is attached.

Attachments

Xpecka2-2009-11-19-21-03-04.log Download (140.0 KB) - added by MMMartin 4 years ago.
Log until crash

Change History

Changed 4 years ago by MMMartin

Log until crash

comment:1 Changed 4 years ago by leonid

Looks like another intel 965 specific issue, it fails to setup window and keeps retrying eating up whole memory.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.8 (including 4.0.8 additions). There was a fix might might be related.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use