VirtualBox

Ticket #5534 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Frequent freezes on fedora 12 (kernel 2.6.31)

Reported by: citroklar Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Host specs: AMD Phenom II X4 955, 8 GB RAM.

On Fedora 12, Kernel 2.6.31 (2.6.31.5-127.fc12.x86_64 #1 SMP) I have frequent freezes of the Windows XP Guest (32bit, 1 CPU assigned). Explanation: I start the vm, it comes up, I can login. Performance feels good. After some seconds the VM hangs for no obvious reason. I can click and point, nothing happens. "top" on the host shows 100% CPU usage for VirtualBox while the VM is in this frozen state. After some seconds (up to 20-30 seconds) the VM will become responsive again, work okay for some seconds, then freeze again. Host logs and VM log do not show anything at the time the guest freezes. Enabling AMD-V makes the problem go away, at least I haven't seen the freezes when I enabled it. Problem might even occur while booting windows.

I would have tried with an older version, but I couldn't compile vboxdrv under F12 (kernel 2.6.31 problem). No lower kernel version available for testing.

3.0.8 under Fedora 11 worked fine and very fast, with AMD-V disabled in the VM config. I think 3.0.10 was okay, too. Not 100% sure if I tried that. Also, I found something about echo 2 > /proc/sys/kernel/perf_counter_paranoid but the parameter had already been set to "2".

dmesg output:

---Snip---
vboxdrv: Trying to deactivate the NMI watchdog permanently...
vboxdrv: Successfully done.
vboxdrv: Found 4 processor cores.
vboxdrv: fAsync=0 offMin=0x5e7 offMax=0x29d5
vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
vboxdrv: Successfully loaded version 3.0.12 (interface 0x00110000).
---Snap---

For more info please ask. Thanks.

Attachments

WH Download-2009-11-22-22-19-22.log Download (46.9 KB) - added by citroklar 4 years ago.
vm log
WH Download-2009-12-06-22-43-59-with-AMD-V.log Download (33.2 KB) - added by citroklar 4 years ago.
AMD-V-enabled log of the hang

Change History

Changed 4 years ago by citroklar

vm log

comment:1 Changed 4 years ago by citroklar

Correction: Enabling AMD-V does NOT help. Tried a few times and now I have the same freezes. Probably not as frequently. But definitely there.

comment:2 Changed 4 years ago by frank

  • Description modified (diff)

Tobias, could you attach a VBox.log file with AMD-V enabled as well?

comment:3 Changed 4 years ago by citroklar

I'm very sorry - this looks like a false alarm. I am unable to reproduce the freezes today, either with or without AMD-V enabled. I haven't installed/updated any software, nor have I (knowingly) changed any settings, so I don't know why it's different today. Please close this defect and sorry for the trouble. Thanks for your quick response, Frank.

comment:4 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Well, if you experience such problems again, reopen this ticket.

Greetings!

comment:5 Changed 4 years ago by citroklar

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Okay, now I have an idea how to reproduce the bug and it involves...time. :-P

My setup is pretty basic, just fedora 12 64 Bit + all available updates + Virtualbox 1) Log into the host, leave the machine running for some time...I'd say at least 6-7 hours. Don't touch it, just leave it idle while you are logged in. Note: Virtualbox doesn't have to be running(!!) 2) Start a VM via the GUI (no matter if AMD-V is enabled or not) and see it hang, "top" shows 100% or more for process "VirtualBox". To produce the hang, you might have to click around in the vm a bit

I hope this helps you guys, if you need anything else please let me know. I'm attaching a log with AMD-V enabled.

Changed 4 years ago by citroklar

AMD-V-enabled log of the hang

comment:6 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use