VirtualBox

Ticket #5531 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

GRE protocol nut supported in NAT mode

Reported by: Reiner1210 Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.0.12 Keywords: GRE NAT
Cc: Guest type: Windows
Host type: Linux

Description

The GRE protocol, used by Windows for VPN connections does not work when connected via NAT mode (I have not tried the bridge mode but I suppose that it is working). Host: Suse 11.1 (32 bit) Guest: Windows XP (32 bit) It was possible to establich a VPN connection from the guest to an other Computer

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by Reiner1210

comment:2 in reply to: ↑ 1 Changed 4 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to invalid

Replying to Reiner1210:

Here some details about GRE

 http://support.microsoft.com/kb/241251/EN-US/

unfortunately it's impossible to do without raw sockets (because GRE is neither UDP nor TCP base protocol). which aren't a solution also, because restrictions of Windows on using raw socket, the one possible way implementing this will remove any difference between NAT and Bridged networking.

comment:3 follow-up: ↓ 4 Changed 4 years ago by Technologov

one possible way implementing this will remove any difference between NAT and Bridged networking.

What do you mean ? How is it possible to remove the difference ?

Those are *fundamentally* different things, and NAT cannot work with *some* payload. (non-standard protocols).

-Technologov

comment:4 in reply to: ↑ 3 Changed 4 years ago by Hachiman

Replying to Technologov:

one possible way implementing this will remove any difference between NAT and Bridged networking.

What do you mean ? How is it possible to remove the difference ?

e.g. ICMP support, require raw socket on Linux/Solaris, but Windows has ICMP API. lack of raw sockets has enforced e.g. nmap use driver instead raw sockets since XP sp2 times. support such protocols like GRE requires raw sockets that is noway on Windows except driver solution. We can't allow ourself to have got much different NAT implementation on Windows, Unix and Darwin, the lat one has own obstacles.

Those are *fundamentally* different things, and NAT cannot work with *some* payload. (non-standard protocols).

-Technologov

comment:5 follow-up: ↓ 6 Changed 4 years ago by Reiner1210

Well if the combination is Linux Host and Windows Guest I think it's possible since the host is Linux which have raw sockets. I think the more important question is how many people will need it? I have discovered this incidentally, but perhaps there are situations where this is needed.

Reiner

comment:6 in reply to: ↑ 5 Changed 4 years ago by Hachiman

Replying to Reiner1210:

Well if the combination is Linux Host and Windows Guest I think it's possible since the host is Linux which have raw sockets. I think the more important question is how many people will need it?

The problem is that NAT should work on all platforms and by adding raw sockets on Linux, we'll have to introduce kernel land code on Windows, to keep functionality consistent.

I have discovered this incidentally, but perhaps there are situations where this is needed.

Reiner

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use