VirtualBox

Ticket #5527 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Extra data being written when file is in a shared folder

Reported by: MuffinFlavored Owned by:
Priority: major Component: shared folders
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

mount -t vboxsf foo /root/shared/ mkdir /root/shared/packets/  http://codepad.org/kcD9DJvN

121 bytes of data becomes 132 bytes of data when written to the files.

fopen must be called with in "a" mode. Functions normally in "w" mode. fflush() does not fix anything.

0x00 appears an extra 11 times in 11.txt

Change History

comment:1 Changed 4 years ago by frank

I cannot reproduce this on a Linux host with a Linux guest. Will try a Windows host soon. Are you sure you have VBox 3.0.12 guest additions installed? Because previous versions had a known bug when writing data in append mode.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Same for a Windows Vista host. I guess you installed the wrong guest additions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use