VirtualBox

Ticket #5479 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

VBoxManage clonehd / clonevdi fails at start

Reported by: VladimirCZ Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.10 Keywords: clonehd, clonevdi
Cc: Guest type: Windows
Host type: Linux

Description

VBoxManage clonehd / clonevdi fails

at start of command: clonevdi XP.vdi XP2.vdi or clonehd XP.vdi XP2.vdi with the following message:

ERROR: Cannot register the hard disk '/media/Win_Slow/Backup_L_Data/VirtualBox/VDI/XP.vdi' with UUID {d647f74e-7fe5-4730-ae98-0454d088272a} because a hard disk '/media/L_Data/VirtualBox/VDI/WinXP Pro EN & Office XP.vdi' with UUID {d647f74e-7fe5-4730-ae98-0454d088272a} already exists in the media registry ('/home/vladimir/.VirtualBox/VirtualBox.xml') Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBox, interface IVirtualBox, callee nsISupports Context: "OpenHardDisk(Bstr(szFilenameAbs), AccessMode_ReadWrite, false, Bstr(""), false, Bstr(""), srcDisk.asOutParam())" at line 624 of file VBoxManageDisk.cpp

It looks like the clonehd has a problem with creating a unique UUID for the new disk.

Host OS: Ubuntu 9.10 64-bit with VBox 3.0.10

Change History

comment:1 Changed 4 years ago by macala

The same error on Host Mac OS: Leopard Snow.

comment:2 Changed 4 years ago by macala

ERROR: Cannot register the hard disk '/Users/adamlasota/VirtualBox/Czyste maszyny/WinXP.vdi' with UUID {af69d29a-11cb-4f13-9af5-129db6fe5c40} because a hard disk '/Users/Shared/WinXP.vdi' with UUID {af69d29a-11cb-4f13-9af5-129db6fe5c40} already exists in the media registry ('/Users/adamlasota/Library/VirtualBox/VirtualBox.xml') Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBox, interface IVirtualBox, callee nsISupports Context: "OpenHardDisk(Bstr(szFilenameAbs), AccessMode_ReadWrite, false, Bstr(""), false, Bstr(""), srcDisk.asOutParam())" at line 624 of file VBoxManageDisk.cpp

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #5497.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use