VirtualBox

Ticket #5440 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Lost Disk Space

Reported by: virtualuser Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.10 Keywords: Hard Disk Free Space Problem
Cc: Guest type: Linux
Host type: Windows

Description

I too experienced the problem described in this ticket  http://www.virtualbox.org/ticket/3410

I had a Virtual Machine Running On Windows 7 running Linux Mint as a Guest OS, during the installation of the Guest OS I encountered an out of space warning. Before the Guest OS I had allocated 8GB while 10GB were free, sometime during the installation of the Guest OS the free disk space warning come up, so I closed out of the Virtual Machine, went to the VirtualBox Media Manager, detached the hard drive and then "removed" it. After doing this and shutting down Virtual Box, Windows Claimed I had only 732 KBs of Free Disk space left. No installation of programs or additional data was implemented during this issue. There is clearly something wrong here, I started out with 10GB of free disk space and now even after removing the Virtal Hard Disk, I'm down to 732 KBs! That is a tremendous unbearable loss. I need a solution as I have programs and personal data on this machine that I wish to retain and do not wish to have to reformat and spend days or even a week reinstalling and configuring and setting up my computer the way I like it due to a flaw in Virtal Box. Please tell me how to recover the disk space that VirtualBox allocated for the Virtal Machine.

Attachments

Virtual_Media_Manager2_Mockup.PNG Download (28.0 KB) - added by Technologov 4 years ago.
Virtual_Media_Manager2_Mockup.png -- New possible GUI design idea. (Demo Mockup)

Change History

comment:1 follow-up: ↓ 5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Remove from the media manager != delete. Find the file you want to delete and delete it yourself.

comment:2 follow-up: ↓ 4 Changed 4 years ago by sandervl73

By the way: this is CLEARLY mentioned in the dialog when you remove the file. Next time please read first and only open defects for real problems.

comment:3 Changed 4 years ago by virtualuser

  • Status changed from closed to reopened
  • Resolution worksforme deleted

No need for an attitude.

I've tried all methods to remove and delete the virtual hard disk, including media manager and in C:\Users\Main User\.VirtualBox\LinuxMintVirtualHardDisk.vdi & *.vdi

Even after this, Disk Space is not restored to what it was before the Virtual Machine creation.

"Find the file you want to delete and delete it yourself." < ????? Really ????? What file are you referring to?

By the way: the CLEARLY mentioned information in the dialog was unhelpful in this issue.

comment:4 in reply to: ↑ 2 Changed 4 years ago by virtualuser

Replying to sandervl73:

By the way: this is CLEARLY mentioned in the dialog when you remove the file. Next time please read first and only open defects for real problems.

Very Rude and Unhelpful.

comment:5 in reply to: ↑ 1 Changed 4 years ago by virtualuser

Replying to sandervl73:

Remove from the media manager != delete. Find the file you want to delete and delete it yourself.

Please tone down the attitude.

What Works For You May not Work for Everyone. Telling a person to find a file and delete it them selfs is rude and unhelpful.

comment:6 follow-up: ↓ 8 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to invalid

Please use the forum for such things. This is the wrong place as a misunderstanding on your behalf can not be qualified as a VirtualBox bug.

comment:7 Changed 4 years ago by virtualuser

  • Status changed from closed to reopened
  • Resolution invalid deleted

This appears to be a bug indeed, this is not normal intended operation for this program. Please look into this and correct it. People don't like losing disk space.

comment:8 in reply to: ↑ 6 Changed 4 years ago by virtualuser

Replying to sandervl73:

Please use the forum for such things. This is the wrong place as a misunderstanding on your behalf can not be qualified as a VirtualBox bug.

Please enlighten me to what it is you assume I'm misunderstanding? This is indeed a bug and thus qualifies as such. The forums are of no help in this matter.

comment:9 follow-up: ↓ 10 Changed 4 years ago by frank

Dear virtualuser, when you remove a medium in the Virtual Media Manager you will be asked if the medium should be really removed (action Delete) or if the image should be kept (action Keep). From your description it seems that you selected Keep, therefore the disk image was only removed from the list of known media but not from your hard disk. This is clearly described in the message box which is popping up when you try to remove a medium in the Virtual Media Manager.

Regarding your problem finding the virtual disk image: Open File / Preferences in the main selector window. In General you will find the default path for virtual disk images. Your virtual disk image is stored there, unless you chose another path when you created the disk image but in that case you should remember the path yourself.

I recommend you to verify the above: Create a virtual hard disk in the disk manager, choose Dynamically expanding storage. The resulting image will occupy only a few kilobytes on your hard disk (because it is dynamically expanding when the guest is writing to the disk). Then open the Virtual Media Manager and select the image you just created. The window will show you the location of the file. Now delete it and read carefully the text in the message box.

Like sandervl73 I assume that you didn't find a bug but just clicked at the wrong button. The Virtual Media Manager is described in the user manual.

And regarding rudeness: Perhaps sandervl73 was a bit shot in his answers but phrases like That is a tremendous unbearable loss and ... need a solution ... do not wish to have to reformat and spend days or even a week ... due to a flaw in VirtalBox is an aggressive tone if you ask me. Sorry, but such a description of a (pretended) bug does not improve our willingness to help you.

comment:10 in reply to: ↑ 9 Changed 4 years ago by virtualuser

Replying to frank:

Dear virtualuser, when you remove a medium in the Virtual Media Manager you will be asked if the medium should be really removed (action Delete) or if the image should be kept (action Keep). From your description it seems that you selected Keep, therefore the disk image was only removed from the list of known media but not from your hard disk. This is clearly described in the message box which is popping up when you try to remove a medium in the Virtual Media Manager.

Regarding your problem finding the virtual disk image: Open File / Preferences in the main selector window. In General you will find the default path for virtual disk images. Your virtual disk image is stored there, unless you chose another path when you created the disk image but in that case you should remember the path yourself.

I recommend you to verify the above: Create a virtual hard disk in the disk manager, choose Dynamically expanding storage. The resulting image will occupy only a few kilobytes on your hard disk (because it is dynamically expanding when the guest is writing to the disk). Then open the Virtual Media Manager and select the image you just created. The window will show you the location of the file. Now delete it and read carefully the text in the message box.

Like sandervl73 I assume that you didn't find a bug but just clicked at the wrong button. The Virtual Media Manager is described in the user manual.

And regarding rudeness: Perhaps sandervl73 was a bit shot in his answers but phrases like That is a tremendous unbearable loss and ... need a solution ... do not wish to have to reformat and spend days or even a week ... due to a flaw in VirtalBox is an aggressive tone if you ask me. Sorry, but such a description of a (pretended) bug does not improve our willingness to help you.

I never said "keep" or "kept" I said "removed" "deleted"

comment:11 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

Sorry, but I don't believe that. If you choose to delete the file then it will be removed.

comment:12 Changed 4 years ago by virtualuser

  • Status changed from closed to reopened
  • Resolution worksforme deleted

The file was removed but the disk space was not restored.

comment:13 Changed 4 years ago by frank

  • Priority changed from critical to major
  • Status changed from reopened to closed
  • Resolution set to worksforme

Well, provide me a reproducible step-by-step scenario. I remove virtual disk images very often using the disk manager and it works just fine (that is, as designed).

comment:14 Changed 4 years ago by Technologov

In "Virtual Media Manager" change term from "Remove" to "Unregister". This will remove user's confusion and unregister this bug from our bugzilla system ! :)

-Technologov

comment:15 Changed 4 years ago by Technologov

virtualuser: Create a new feature-request, where "Virtual Media Manager" will add a button to delete files from Hard Disk.

comment:16 Changed 4 years ago by Technologov

Frank: "Remove" in English is too broad, generic term. It may mean remove VDI file from hard disk, or just remove it from the media manager. It is better not to use it in this case.

comment:17 Changed 4 years ago by frank

That's not the point. There is only one Remove button in the media manager, and, after pressing it, a dialog box appears. That dialog box contains three buttons, the first two buttons are described in detail. Cancel is not described but that one should be obvious.

The point is that we would really like to fix something if there would be a bug but so far I didn't see it.

Changed 4 years ago by Technologov

Virtual_Media_Manager2_Mockup.png -- New possible GUI design idea. (Demo Mockup)

comment:18 Changed 4 years ago by frank

Alexey, I think you still don't get the point. Did you have a look at the current dialog which appears after you press Remove?

comment:19 Changed 4 years ago by Technologov

Yes, I see the 3 buttons. It looks good to me. But is there better way ?

frank and virtualuser: I was able to quickly draw a new GUI proposal. The goal is to make things clear for all users. The last stage dialog with 3 buttons will be removed in this case. This design is more transparent.

What do you think of it ?

-Technologov

comment:20 Changed 4 years ago by Technologov

As for me personally, I am happy with the current design.

comment:21 Changed 4 years ago by frank

Yes, I'm happy with the current design as well (thanks Alexey for your proposal anyway) until someone explains me that it is wrong or non-intuitive but I would like to understand the problem.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use