VirtualBox

Opened 15 years ago

Closed 9 years ago

#5436 closed defect (obsolete)

Windows guest hangs when plugging USB network adapter

Reported by: operon Owned by:
Component: USB Version: VirtualBox 3.0.10
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

This started to happen on 3.0.10 (possibly 3.0.8 as well). I have a WiFi USB adapter that I use to test applications on windows (Belkin F5D7050B). After intalling drivers, the installer asks to plug the adapter, but the guest times out saying "couldn't find adapter". After restart, the adapter appears correctly on Control Panel > System > Hardware > Device Browser, but doesn't work at all. Any changes done to the device (e.g. re-loading driver) hangs the application until the usb adapter is unplugged from the guest.

Attachments (4)

VBox.log (61.2 KB ) - added by operon 15 years ago.
log file
VBox.log.1 (72.2 KB ) - added by operon 15 years ago.
another log file
VBox.log.2 (56.7 KB ) - added by operon 15 years ago.
Latest Nov 10, 2009 log
VBox.log.Nov10-2 (56.9 KB ) - added by operon 15 years ago.

Download all attachments as: .zip

Change History (9)

by operon, 15 years ago

Attachment: VBox.log added

log file

by operon, 15 years ago

Attachment: VBox.log.1 added

another log file

comment:1 by operon, 15 years ago

I tested on 3.0.8 and wasn't working either, but when I reverted these instructions: http://www.virtualbox.org/wiki/USB_on_Fedora_6 to follow these http://forums.debian.net/viewtopic.php?f=16&t=33857 instead, it all started to work, so it might have just been a permissions issue. I will try upgrading and report the result here.

by operon, 15 years ago

Attachment: VBox.log.2 added

Latest Nov 10, 2009 log

comment:2 by operon, 15 years ago

I confirm that USB network adapter still hangs on 3.0.10, reverting to 3.0.8 solves the issue. Attached latest log file (Nov 10).

comment:3 by operon, 15 years ago

Did a bit more testing... the network adapter likes to be plugged and unplugged twice before it will start working. I have no idea why though. I will attach my last log file as soon as I submit this comment.

by operon, 15 years ago

Attachment: VBox.log.Nov10-2 added

comment:4 by operon, 15 years ago

BTW, I forgot to mention is now working on 3.0.10. I bet is a Windows issue (I would not be surprised)

comment:5 by Frank Mehnert, 9 years ago

Resolution: obsolete
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use