VirtualBox

Ticket #5422 (closed defect: fixed)

Opened 4 years ago

Last modified 16 months ago

SQL Server faults during install if guest nas multiple CPUs enabled.

Reported by: anon4321 Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

During the setup of Microsoft SQL Server 2005, if the guest has multiple CPUs enabled, the SQL Server service will fail to start. If the guest is switch to one CPU, the install is successful. Switching to multiple CPUs after installing under one CPU works but will result in significant performance issues in the VM.

Host is Windows 7 x64, the guest is Windows 2003 R2. Both host and guest are update to date with respect to windows update (SPs, hotfixes etc).

Attachments

SharePoint Development x64 Test-2009-11-07-10-34-24.log Download (51.2 KB) - added by anon4321 4 years ago.
VB log

Change History

comment:1 Changed 4 years ago by anon4321

I have a Watson dump/minidump for sqlservr.exe during the setup. However, it is too big to attach.

Changed 4 years ago by anon4321

VB log

comment:2 Changed 4 years ago by anon4321

I recently rebuild an environment including SQL Server without problems.

As I cannot reproduce this, please close this ticket.

comment:3 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 16 months ago by atmanning

I have attempted to install SQL Server 2012 on a VBox 4.2.6 guest Windows Server 2008 x64 with consistent failure. The process gets into an endless loop (12 hours). I installed .NET 4.0 separately in a very long process (~1 hour) but it finally succeeded. SQL Basic database services fails in an endless loop at 100% cpu When finally killing the installation process, the installation error

Microsoft .NET Framework 4.0 installation has failed with exit code 1073807364

is displayed

Configuration: VBox 4.2.6 Base Memory: 1863MB, IO APIC, PIIX3 chipset, absolute pointing device 1 processor, no extended features Enabled VT-x/AMD-V, Nested Paging

This was the only ticket I found referring to problems with SQL server installation problems on a VBox guest OS. Any references to newer tickets regarding this kind of problem?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use