VirtualBox

Ticket #5397 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

guest Vm starts and stops immediatly

Reported by: enumaelis Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hi,

I have Ubuntu karmic 9.10 4gb RAM, with xp as guest.I upgraded Virtualbox to 3.0.10 and after upgrading did see 2 problems.

The firs is that when i start the xp guest the vm starts and stop immediatly. I did a check and if i create a new machine this one starts correctly. Here is what it says when starting virtualbox:

/usr/lib/virtualbox/VirtualBox -startvm winxp
Qt WARNING: X Error: BadRequest (invalid request code or no such operation) 1
  Extension:    156 (Uknown extension)                                       
  Minor opcode: 19 (Unknown request)                                         
  Resource id:  0x17                                                         
VirtualBox: ../../src/xcb_io.c:542: _XRead: Asserzione 'dpy->xcb->reply_data != ((void *)0)' fallita. (assertion failed)
Aborted (core dump created).


I also created a coredump bzipped of about 5 MB in case i can send it.

The second problem is that now virtualbox detects only 2560 MB of memory instead of 4gb, while it was able to detect all the memory before. Please note that linux sees normally 4 gb of ram, as the kernel (version 2.6.31.14 modified) is compiled PAE. Attached is also the log of the vm when starting

Attachments

winxp-2009-11-05-20-09-53.log Download (744 bytes) - added by enumaelis 4 years ago.

Change History

Changed 4 years ago by enumaelis

comment:1 Changed 4 years ago by frank

The VBox.log file says your host has 3890MB which sounds plausible (some RAM is reserved for the kernel). I've sent you a private E-mail regarding the core dump.

comment:2 Changed 4 years ago by frank

  • Host type changed from other to Linux

comment:3 Changed 4 years ago by enumaelis

The problem is solved. After You told me that it was probably a matter of 3d acceleration, I checked the Ati drivers that were installed but not active. I removed the drivers and now it works perfectly. So if ATI is installed and not active VM doesn't start or better stops immedialty after starting. I suppose that with ATI installed AND active it will work either. I will check. Thanks for now

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use