VirtualBox

Ticket #5395 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Linux Guest Additions cause animated cursor flicker

Reported by: PassinThru Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: other
Host type: other

Description

I'm running an Ubuntu 9.10 guest in VirtualBox 3.0.10 on a Windows XP SP3 host on a 2GB dual-core Dell Latitude D620 laptop. After installing 9.10 and updating to all the latest packages, the system runs fine, and animated/busy cursors are clean and solid. After installing Linux Guest Additions, the busy cursor flickers madly, to the point of distraction. Sometimes it will stay busy until I click outside of VirtualBox and then click back in again. This occurs in Ubuntu versions back to at least 8.04, as far back as I tested. In an attempt to eliminate the laptop hardware, I booted into Ubuntu directly, and again, the busy cursor was clean, solid and flicker-free.

Attachments

Ubuntu 9.10-2009-11-05-08-56-42.log Download (35.5 KB) - added by PassinThru 4 years ago.
Latest VirtualBox log file

Change History

Changed 4 years ago by PassinThru

Latest VirtualBox log file

comment:1 Changed 4 years ago by frank

Still an issue? This sounds like an issue of your host graphics driver. Without guest additions installed, the mouse cursor is drawn by the guest. With guest additions installed, the host will display the cursor and probably use a hardware mouse cursor. The flicker might happen when the cursor image changes to the next image of the animated sequence. In that case I assume the same happens if you select animated cursors for the host.

comment:2 Changed 4 years ago by PassinThru

No, the issue is gone. To be honest, I don't recall when it happened. To my knowledge, my host graphics driver has not been updated, but it's possible it was during automatic updates. I'm running Ubuntu 10.04 now, and the latest VirtualBox (I think - 3.2.8r64453) doesn't exhibit the problem.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use