VirtualBox

Ticket #5390 (closed defect: fixed)

Opened 4 years ago

Last modified 14 months ago

Bridged guest network stops responding after a while

Reported by: brunosimioni Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.10 Keywords: host bridged network
Cc: brunosimioni@… Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

That's the bug scenario:

Host

Sun VirtualBox 3.0.10 PUEL
Microsoft Windows 2003 Server R2 SP2
(A) Broadcom NetXtreme Gigabit Ethernet Adapter (Internal network)
(B) Intel(R) Pro/1000 PT Server Ethernet Adapter (External network)

Guest

VirtualBox Guest Addition 3.0.10 PUEL
Linux Slackware 12.2, with SMP (2 cores)
Shared Folders through vbox file system
2 Intel PRO/1000 MT Desktop connected in (A) and (B), in bridged network mode. One of them have an external IP, and the another one, internal IP

Problem

Guest network adapter freezes (and get unreacheable) sometimes, preventing access via network from host, or outside the host, when running a in bridged network connection mode. However, from guest and inside it, I have external network acess, normally.

I cannot reproduce (and don't know how) this error, and the problem get solved turning guest machine off, and repairing host network connections (bridged connections), and finally, restarting guest machines.

Logs

That's maybe related to the end of the log.
 http://pastebin.org/48344

Attachments

Vbox.log Download (38.9 KB) - added by brunosimioni 4 years ago.
Virtual box log file

Change History

comment:1 in reply to: ↑ description Changed 4 years ago by misha

Replying to brunosimioni: Just to make sure I understand you correctly, am I right that you have problem only with to-guest connections, i.e. host->guest, external->guest, while all host->guest/external & guest->host/external connection work ok?
If so, are you sure you do not have any firewall running on guest preventing incoming connections? Does this happen with any guest OS ?
Also, what kind of "repairing host network connections" do you need to do to recover from this issue?

Could you also please attach the log to this ticket directly rather than to pastebin?

Changed 4 years ago by brunosimioni

Virtual box log file

comment:2 follow-up: ↓ 3 Changed 4 years ago by brunosimioni

Replying to misha:

Just to make sure I understand you correctly, am I right that you have problem only with to-guest connections, i.e. host->guest, external->guest, while all host->guest/external & guest->host/external connection work ok?

I have problems only on host->guest and extenal->guest connections. Guest->host and guest->external are ok.

If so, are you sure you do not have any firewall running on guest preventing incoming connections? Does this happen with any guest OS ?

There is no firewall and this problem happens occasionally. I really dont know if it happens with any guest OS. There is someone who reply my virtual box forum topic, with another scenario, but apparently the same problem. That's the topic:  http://forums.virtualbox.org/viewtopic.php?f=2&t=23784[[BR]]

Also, what kind of "repairing host network connections" do you need to do to recover from this issue?

Shutdown guest OS, and on Windows, right-click on bridged network adapters, "Repair", and finnally, restart guest OS. Only restart guest OS, without repairing network adapters, does not solve the problem. Only repairing connections, without turning machines off, also does not solve the problem.

I'm attaching the log file to this bug.

comment:3 in reply to: ↑ 2 Changed 4 years ago by misha

Replying to brunosimioni:

Shutdown guest OS, and on Windows, right-click on bridged network adapters, "Repair"

You typically would not need to bridge any host adapters from windows host perspective to use VBox bridged networking, instead you just need to specify the adapter to bridge to in VM settings.
What kind of adapters do you have bridged together on your win host, and why? I just what to understand your environment and a use-case to reproduce.

comment:4 Changed 4 years ago by brunosimioni

Misha, apparently the problem was not explained correctly.

On host machine, I have two network cards. One of this card is configured with an valid (external - internet network) ip. The other one, with one internal network ip (internal network). Both network cards are configured normally without any bridged mode, ou virtual interfaces.

On VirtualBox, I set this both network card as bridged network interfaces, on my virtual machine.

On guest OS, I set (again) two different ips for this both bridged network interfaces. For the guest external bridged network interface, an external ip (different from host external ip, but external and valid). For the guest internal bridged network interface, and internal ip (different from the host internal ip).

So, that's my example scenario (that's not real ips):

HOST NETWORK INTERFACES
(A) Network Card1
(B) Network Card2
(C) Virtualbox Network Card1
(D) Virtualbox Network Card2

HOST MACHINE GUEST MACHINE
(A) [010.x.x.1/24] INTERNAL --network-bridge--> (C) [010.x.x.2/24] INTERNAL
(B) [189.x.x.1/24] EXTERNAL --network-bridge--> (D) [189.x.x.2/24] EXTERNAL

comment:5 Changed 4 years ago by Licho

Having same problem with both host-only and bridge networking. Its very old bug, not new in 3.0.10..

comment:6 Changed 4 years ago by brunosimioni

Problem not solved yet, on Vbox 3.0.12.

comment:7 Changed 4 years ago by Licho

It appears that problem can be fixed by using virtio-net adapter!

comment:8 Changed 3 years ago by frank

Still relevant? I so, can this problem be reproduced on a Linux host?

comment:9 Changed 3 years ago by Licho

Last time i checked it was valid. IT happens on linux for me (64bit ubuntu host, win2k3 guest).

I fixed it by using different driver (paravirtual network drivers)

comment:10 Changed 3 years ago by frank

In that case I would be interested in a  core dump for a Linux host. If you have time to reproduce this issue with the E1000 or PCNet device please contact me at frank _dot_ mehnert _at_ oracle _dot_ com. Unfortunately I'm not able to reproduce this problem here.

comment:11 Changed 14 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use