VirtualBox

Ticket #5389 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Guru meditation when resetting OpenSolaris guest -> fixed in SVN

Reported by: woongbin@… Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: other
Host type: other

Description

I'm using OpenSolaris 200906 (x86) on Windows 7 host (x64) with Intel VT on. I restarted the X server and the virtual machine crashed. This is not reproducible but I thought it might be a good idea to submit this log anyways.

Attachments

Logs.zip Download (21.5 KB) - added by woongbin@… 4 years ago.
vbox.log and vbox.png
VBox.log Download (125.0 KB) - added by woongbin@… 4 years ago.
VBox.2.log Download (140.1 KB) - added by mduft 4 years ago.
my guru meditation - should be the same as the already fixed one, right?

Change History

Changed 4 years ago by woongbin@…

vbox.log and vbox.png

comment:1 Changed 4 years ago by woongbin@…

Okay. I think I know how to reproduce this now. Use 3D acceleration (compiz). Suspend the machine, restore and the VM freezes there. Now if you reset the machine twice, this happens.

comment:2 Changed 4 years ago by woongbin@…

Even more strange, this happens regardless of 3D acceleration now. I am going back to 3.0.8 until this is resolved.

Changed 4 years ago by woongbin@…

comment:3 Changed 4 years ago by sandervl73

Unable to reproduce with a virgin opensolaris 200906 install (+ guest additions).

comment:4 Changed 4 years ago by woongbin@…

Hi sandervl73, did you try it with SMP on many times (more than twice maybe)? Thanks

comment:5 Changed 4 years ago by sandervl73

I didn't see the freeze with 2 VCPUs, but the guru meditation indeed occurs when resetting the machine.

comment:6 Changed 4 years ago by sandervl73

  • Summary changed from Guru meditation to Guru meditation when resetting OpenSolaris guest -> fixed in SVN

I've fixed the guru meditation, but am not able to reproduce the freeze.

comment:7 Changed 4 years ago by mduft

i'm seeing similar problems too. i have an opensolaris guest (with compiz enabled) on a gentoo linux box (vbox 3.0.10).

after some time of working over ssh, i sometimes loose connection to the box (reconnecting yields: no route to host). then when i look at the screen of the box, i see only garbage (some content from other windows on my screen, looks like missing some redraws...). now _sometimes_, if i click inside the vm, parts of the screen are restored. if i click around a little bit, i can restore the whole screen, restart the ssh service, and i'm fine again.

but other times the whole machine seems frozen, and only a reset helps. now this time, when i resetted, i got the guru meditation - good to see this one is fixed already.

my osol has vbox additions installed, and is a rather clean install from osol 200906. i only installed sunstdudio, git, svn, cvs, and run the compiler several 1000 times :)

Changed 4 years ago by mduft

my guru meditation - should be the same as the already fixed one, right?

comment:8 Changed 4 years ago by sandervl73

mduft: correct, that's the one I fixed yesterday.

comment:9 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use