VirtualBox

Ticket #5311 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Win7 x64 Sudden Crash

Reported by: darkfate Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Windows 7 x64 suddently crashs without any visible reason. Maybe a dump can help?

Attachments

102809-46878-01.dmp Download (281.9 KB) - added by darkfate 4 years ago.
VBox.log Download (39.7 KB) - added by zosX 4 years ago.
Log at time of BSOD

Change History

Changed 4 years ago by darkfate

comment:1 Changed 4 years ago by sandervl73

What were you doing at the time? No trace of VirtualBox.

comment:2 Changed 4 years ago by darkfate

I tried to start my Debian Lenny x64 guest.

comment:3 Changed 4 years ago by sandervl73

Does it always crash the system? If not, please attach the VBox.log of such a session.

comment:4 Changed 4 years ago by darkfate

No, it is not always crashing. 99% of my working time it does great job. But at this time it must has been for sure VirtualBox, because my sys crashed while i have clicked on the start button after i selected my debian x64 vmachine.

I already tested my memory for faults and so on... so my sys seems to be ok.

comment:5 Changed 4 years ago by zosX

I have a similar problem, and there seem to be some other reports here of Windows x64 hosts crashing when hardware VT is enabled on AMD processors. In my case I get intermittent BSODs. I am running an AMD Turion QL-62. The BSOD that virtualbox causes is the timer failing on the second core. This is with VT and ioapic enabled. Though, I believe that even with apic disabled I've seen a BSOD before. It was far worse under 3.04....waiting until 3.06 it seemed pretty flawless, but now with 3.08 I am getting intermittent BSODs again, especially if I reboot the VM. I can attach any logs you may want. Though, to be honest, I looked through the VBOX log and the times were off by two hours which is really odd. (I do just hibernate the host and save the vm state all the time, so maybe they were out of sync somehow??) The log also lacked any relevant information to the crash and the windows dump was just a generic stop dump with no files attached to the crash. It looks like you guys have some issues with your synchronization on AMD cores. I've tortured this laptop for long periods of time with both cores spiked to the max and really had no problems except with virtualbox, so I am a lot less inclined to believe that there is something wrong with my hardware. Stress testing will overheat the machine, but the BSODs generally occur when the laptop is running cool, so I don't believe heat to be an issue....

It *is* intermittent, and therefore hard to reproduce. Also the less I BSOD my host the less chance I invite corruption to precious system files and I would really prefer to keep my current installation stable to be honest. Running ubuntu 9.04 right now and no bsod.....yet....

Let me know if I can provide anything and thanks.

comment:6 Changed 4 years ago by zosX

Seems worse under 3.10. 3.09 was more stable. My first instance of 3.10 BSODed the host. I'll attach my VBOX log...I can attach the windows dump too, but it was a pretty generic stop error....

Additional information about the problem:

BCCode: 101 BCP1: 0000000000000061 BCP2: 0000000000000000 BCP3: FFFFF880009EA180 BCP4: 0000000000000001 OS Version: 6_1_7100 Service Pack: 0_0 Product: 256_1

I've heard that bad cores can exhibit this stop, but nothing in windows that multithreads seems to cause this, only virtualbox.........

Changed 4 years ago by zosX

Log at time of BSOD

comment:7 Changed 4 years ago by zosX

Looks like IO APIC. Disabled and no BSODs (yet)....I'll update this after I've tested some more.

comment:8 Changed 4 years ago by zosX

Also from a lot of googling it appe ars that a lot of bioses out there are having issues with AMD-V. Apparently M$ is working on a workaround, and there seems to be a hotfix for x68 vista, so the issue may not really be with virtualbox, but in how windows is interacting with the bios, as users running virtual pc are having similar problems, though vmware is reportedly ok. 2 cores are better than one and it would be cool to see a workaround or have this fixed though........

comment:9 Changed 4 years ago by Technologov

I have Win 7, x64 host and it is rock-stable.

Host: Windows 7, x64, Core 2 Q6600, VBox 3.0.10

What could be the difference?

-Technologov

comment:10 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use