Ticket #5295 (reopened defect)

Opened 7 years ago

Last modified 7 weeks ago

Shared folders cannot be exported via NFS

Reported by: moppel Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.10 Keywords: mount nfs exports shared folder nohide
Cc: Guest type: Linux
Host type: other

Description (last modified by aeichner) (diff) virtual maschine with additional mounted ext3 and vboxsf partition (shared folder) any extern PC or other, with need to access of the shared folder of the virtual maschine

Commands on the extern PC: "mount -t nfs ..." works well. "mount -t nfs ..." does not work. (mount.nfs access denied by server while mounting

Configuration files on (linux virtual maschine): /etc/fstab: ... /dev/hda3 /mnt/ext3 ext3 rw,nodev 0 2 vboshare /mnt/shared-folder vboxsf rw,nodev 0 2

/etc/exports: /mnt/ext3,async,nohide) /mnt/shared-folder,async,nohide)

/etc/hosts.allow: portmap: mountd:

Command "df -h" on the virtual maschine with shared folder: ... /dev/hda3 2,3G 68M 2,1G 4% /mnt/ext3 vboshare 200G 43G 157G 22% /mnt/shared-folder

The issues are checked with 32-bit and 64-bit virtual maschines debian 4.0, debian 5.0 and ubuntu 8.04. Because the problem not occurs with similar mounted ext3 partitions, it seems, the problem is connected with vboxsf partitions = shared folders.

Change History

comment:1 Changed 7 years ago by moppel

Host type: Debian Lenny 64-Bit

Guest type: Debian Lenny 64-Bit

comment:2 Changed 7 years ago by frank

  • Version changed from VirtualBox 2.2.4 to VirtualBox 3.0.10
  • Summary changed from mount -t nfs ... of shared folders does not work to Shared folders cannot be exported via NFS

Confirmed with VBox 3.0.10. When using an nfs-kernel-server, the server wouldn't start with exportfs: Warning: /foo does not support NFS export. So some extension is probably not properly implemented.

comment:3 Changed 2 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

comment:4 Changed 7 weeks ago by ams

  • Status changed from closed to reopened
  • Resolution obsolete deleted

Same occurs with VirtualBox 5.1.4.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use