VirtualBox

Ticket #5261 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

BSOD on Windows XP host on guest machine close

Reported by: mkostrze Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

On VirtualBox 3.0.8, guest Vista SP2, host Windows XP SP3 I got BSOD on VM closing (when you close the machine by clicking on 'close' button on the window title bar and select 'power off the machine). It's not deterministic, yet happened 2 times. The BSODs lasted for split second I noticed something like BAD_POOL_CALLER, I'm attaching the log from the latest section.

Attachments

VBox.log Download (42.6 KB) - added by mkostrze 5 years ago.

Change History

Changed 5 years ago by mkostrze

comment:1 Changed 5 years ago by mkostrze

I forgot to add this: I'm using VirtualKD patch on VritualBox so it may be that reason (?) but I've never encoutered such problem before (with previous versions of VirtualBox)

comment:2 Changed 5 years ago by frank

I'm sorry but I really can imagine that VirtualKD is the reason for the problem. The package ships a modified VBoxDD.dll package which usually fits to one particular package (they mention VBox 3.0.4)!

comment:3 Changed 5 years ago by mkostrze

Well, this is why I mentioned it. However:

  • they claim that it will work with whole branch, all that's needed is to recompile VirtualKD with appropriate VirtualBox sources - I did it.
  • I contacted them (yesterday) to confirm it works on 3.0.8 and they said that it works.
  • I've been using it successfully w/ 2.X branch of VirtualBox with no no problems.

Is there anything else but that log I can to provide you?

comment:4 follow-up: ↓ 5 Changed 5 years ago by mkostrze

Also - I'll try to replicate it w/o VirtualKD installed, so please don't close this issue yet ;)

comment:5 in reply to: ↑ 4 Changed 5 years ago by misha

Replying to mkostrze: If the issue is still relevant w/o VirtualKD installed, could you attach a  minidump for the crash so we could identify the cause.

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

no response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use