VirtualBox

Ticket #5178 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Upgrade from 2.2.4 to 3.0.8, stale GA reference - inaccessible

Reported by: aimone Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: Solaris
Host type: Windows

Description

After upgrading from 2.2.4 to 3.0.8 the GUI complained about some CD images not being accessible. It turns out a reference to the 2.2.4 GA iso still exists in the XML file, but the iso itself is gone.

The Media Manager would not allow me to remove the stale entry even though it clearly displayed a message about the path being invalid.

My guess at the cause for this would be the fact that the location of the GA iso moved, so the upgrade added a path for the new one, but it never cleaned up the old one. Hence the stale [frozen] entry for a nonexistent iso.

To work around this I removed 3.0.8, installed 2.2.4 again, snagged a copy of the GA iso, removed 2.2.4 and installed 3.0.8 again, then edited the XML file to have the path to the copy I'd made of the 2.2.4 GA iso.

To avoid the potential for this happening on the next upgrade, I've already snagged a copy of the GA iso...

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

That's a known problem and I'm pretty sure there's an open ticket for it already. We are working to get rid of such issues.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use