VirtualBox

Ticket #5175 (reopened defect)

Opened 5 years ago

Last modified 3 weeks ago

"failed to created a proxy device for the usb device" message when attaching USB dongle to guest

Reported by: Murz Owned by:
Priority: major Component: USB
Version: VirtualBox 3.0.8 Keywords: amicon vpn sberbank
Cc: Guest type: Windows
Host type: Linux

Description

I have using Virtualbox on Debian Lenny (Squeeze) AMD64 as host and Windows XP as guest. All USB flash drives, mouse, keyboard succcesfully connects from host to guest via Virtualbox. But I have a hardware VPN key (AMICON VPNLDR 1.5 device) that connects to Windows XP as host normally, succesfully connects to guest via any virtualbox on Ubuntu Jaunty, but I can't connect it on Debian Lenny (that is installed on server, Ubuntu - on client computers).

When I insert this device, in messages I see:

Oct  9 16:00:57 beam kernel: [103940.864726] usb 4-2: new full speed USB device using ohci_hcd and address 4
Oct  9 16:00:58 beam kernel: [103941.077039] usb 4-2: New USB device found, idVendor=a420, idProduct=5420
Oct  9 16:00:58 beam kernel: [103941.077042] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct  9 16:00:58 beam kernel: [103941.077045] usb 4-2: Product: VPNLDR 1.5
Oct  9 16:00:58 beam kernel: [103941.077047] usb 4-2: Manufacturer: AMICON
Oct  9 16:00:58 beam kernel: [103941.077133] usb 4-2: configuration #1 chosen from 1 choice

When I start the guest and try connect this device to it, the Virtualbox interface hang to about 8-10 seconds and after that I see the error:

Failed to attach the USB device AMICON VPNLDR 1.5 [0100] to the virtual machine oldlinux_image.
Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR).
Details:

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {0a51994b-cbc6-4686-94eb-d4e4023280e2}

And after that device stay disconnected. In VBox.log I see the error:

00:07:39.487 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={0a51994b-cbc6-4686-94eb-d4e4023280e2} aComponent={Console} aText={Failed to create a proxy device for the USB device.  (Error: VERR_READ_ERROR)} aWarning=false, preserve=false

I try to start virtualbox via normal user, priveleged user (in group root, adm, sudo, ...) and via root, but always see this error. I try to create filters for this device, but it isn't helps.

This device is a hardware VPN key for the Sberbank Client Bank software, that is very popular in Russia and many of organisation use it.

How can I fix the problem? Which folders, files or processes is depend on virtualbox mount process?

Change History

comment:1 Changed 5 years ago by Murz

Not only I have this problem, in forum there are another user that have the same problem:  http://forums.virtualbox.org/viewtopic.php?f=1&t=15244&start=0

comment:2 Changed 4 years ago by quackking

Same problem, host is Virtualbox 3.08 on Karmic host (using AMD64 tri-core MB, but not using the AMD64 kernel, using i386-PAE kernel) - guest ins WinXP SP3. The device is a Philips SPC610NC webcam connecting to a USB hub.

comment:3 Changed 4 years ago by Murz

The problem is still here in 3.0.10 version. Can developers tell us some additional info about this bug?

comment:4 Changed 4 years ago by Murz

Bug is still here on 3.1.0 and 3.1.2 versions.

comment:5 Changed 4 years ago by umlguy

I get this exact same type of error when trying to attach a Palm device for syncing to Outlook within my Windows VM. I'm using 3.1.4 on Ubuntu 9.10.

comment:6 Changed 4 years ago by sylerner

I am getting the same problem with a Logitech Webcam Pro 9000 attaching to Virtualbox 3.1.6 running on openSUSE 11.0 64bit, Intel Core2 Q6600 with two cores assigned to VB.

Failed to attach the USB device Unknown device 046D:0809 [0010] to the virtual machine Windows XP.
Failed to create a proxy device for the USB device. (Error: VERR_FILE_NOT_FOUND).

comment:7 Changed 4 years ago by ruffieux

I am getting exactly the same problem with my Logitech Force 3D Pro joystick. I am using 3.1.6 on Ubuntu 9.10.

I have discovered that the revision of the device does not get reported consistently. Could this be the problem.

Using the VboxManage command the device is reported as follows:

UUID: 4c74970f-e167-477c-b2b7-a325dc36ffc1 VendorId: 0x046d (046D) ProductId: 0xc286 (C286) Revision: 16.0 (1600) Manufacturer: Logitech Product: Logitech Force 3D Pro Address: sysfs:/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-2//device:/dev/bus/usb/004/002 Current State: Busy

If I however add a filter in VirtualBox I can see the device but there the revision is 1000.

Hope this helps

comment:8 Changed 4 years ago by ruffieux

I just installed Virtualbox 3.1.8 .... still the same problem on Ubuntu 9.10 :-(

comment:9 Changed 4 years ago by wangrui

Same problem virtualbox-3.2_3.2.0-61806~Ubuntu~lucid_i386.deb on Ubuntu 10.04

comment:10 Changed 4 years ago by Kallisto

Cannot attach an USB Flash Drive to Windows XP 32-bits VirtualBox 3.2.0 guest on my Ubuntu Desktop 10.04 64-bits.

$ dmesg
[ 7139.800037] usb 2-2: new high speed USB device using ehci_hcd and address 3
[ 7139.943026] usb 2-2: configuration #1 chosen from 1 choice
[ 7140.015300] Initializing USB Mass Storage driver...
[ 7140.015409] scsi8 : SCSI emulation for USB Mass Storage devices
[ 7140.015532] usb-storage: device found at 3
[ 7140.015534] usb-storage: waiting for device to settle before scanning
[ 7140.015546] usbcore: registered new interface driver usb-storage
[ 7140.015549] USB Mass Storage support registered.
[ 7155.013472] usb-storage: device scan complete
[ 7155.014588] scsi 8:0:0:0: Direct-Access     USB 2.0  Flash Disk       0.00 PQ: 0 ANSI: 2
[ 7155.015015] sd 8:0:0:0: Attached scsi generic sg6 type 0
[ 7155.017753] sd 8:0:0:0: [sdf] 2007040 512-byte logical blocks: (1.02 GB/980 MiB)
[ 7155.018767] sd 8:0:0:0: [sdf] Write Protect is off
[ 7155.018770] sd 8:0:0:0: [sdf] Mode Sense: 00 00 00 00
[ 7155.018773] sd 8:0:0:0: [sdf] Assuming drive cache: write through
[ 7155.020695] sd 8:0:0:0: [sdf] Assuming drive cache: write through
[ 7155.020699]  sdf: sdf1
[ 7155.097701] sd 8:0:0:0: [sdf] Assuming drive cache: write through
[ 7155.097706] sd 8:0:0:0: [sdf] Attached SCSI removable disk

VirtualBox error message:

Failed to attach the USB device USB Mass Storage Device [0100] to the virtual machine Windows XP SP3 2008-12.
Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR).
Details:
Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

My AVERTV Hybrid Ultra USB tuner can be connected to the same guest without any problem.
I also tried to attach the USB Flash Drive to another WinXP guest on my desktop and got the same error.

comment:11 Changed 4 years ago by Kallisto

The problem is still here with virtualbox-3.2_3.2.2-62298~Ubuntu~lucid_amd64.deb. The same error message.

comment:12 Changed 4 years ago by Kallisto

I have tested some USB drives with VirtualBox 3.2.4, here the results: 1Gb FAT32 Bootable to MS-DOS - "Failed to create proxy device" 256Mb FAT32 Bootable to MS-DOS - OK 1Gb FAT32 Bootable to SysLinux (Ubuntu Netbook Remix USB Installer) - OK 16Gb NTFS Not bootable - OK 2Gb FAT16 Not bootable - OK 2Gb FAT16 Not bootable - OK Can't find a workaround for my 1Gb drive.

comment:13 Changed 4 years ago by Kallisto

Seems, my problem with 1Gb USB drive was fixed in VirtualBox 3.2.6

comment:14 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still reproducible with VBox 3.2.8.

comment:15 Changed 4 years ago by alibabashack

  • Status changed from closed to reopened
  • Resolution fixed deleted

Error still persists with Saitek X52 pro joystick on Ubuntu Lucid 10.04 (host), Win7 32bit (guest), virtualbox version 3.2.8

00:00:03.207 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR)} aWarning=false, preserve=false

comment:16 Changed 4 years ago by Murz

Same problem with SonyErricsson C702 mobile phone, connected via usb, host is Ubuntu Lucid, guest is Windows XP 32bit, error is: 96:38:14.452 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR)} aWarning=false, preserve=false

Vbox version 3.2.8-64453~Ubuntu~lucid

comment:17 Changed 4 years ago by wangrui

My problem has been solved. After I changed from ubuntu 10.04 i386 to ubuntu 10.04 AMD64 and installed all updates. My USB device works. I thinks this issue is more related to OS because I'm using the same version of virtualbox (but amd64 than i386) and it works now.

comment:18 Changed 4 years ago by brihuega

I have the same problem with a USB-to-IDE bridge in VBox 3.2.8 on Linux AMD64 host.

comment:19 Changed 3 years ago by skuda

Same problem here with Arch Linux with 2.6.38 x86_4 and VirtualBox 4.0.4

comment:20 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Should not happen with VBox 4.0.6. Please make sure that the current user is member of the vboxusers group.

comment:21 Changed 3 years ago by skuda

Actually 4.0.6 it is worse, i can't connect usb devices to the guest machine anymore, in the guest menu, "Devices" i can't open the "USB Devices" section to select any devices connected to the host machine.

You can see other people with the same problem here  https://aur.archlinux.org/packages.php?ID=9753 and in a google search in internet.

comment:22 Changed 3 years ago by frank

So did you add the current user to the vboxusers group?

comment:23 Changed 3 years ago by skuda

Yeah i have ever been member of the vboxusers group, i have downgraded to 4.0.4 and i am functioning normally.

comment:24 Changed 3 years ago by frank

Which 4.0.6 package (exact package name) did you install?

comment:25 Changed 3 years ago by skuda

I used the aur package for Arch Linux "virtualbox_bin" that uses VirtualBox-4.0.6-71344-Linux_amd64.run and i have installed later the oracle extensions package.

comment:26 Changed 3 years ago by skuda

I have applied the solution posted in this url  http://forums.virtualbox.org/viewtopic.php?f=1&t=40922&start=15#p184248 and now it works with 4.0.6

comment:27 Changed 3 years ago by michael

Was that file (10-vboxdrv.rules) not created by the installer?

comment:28 Changed 3 years ago by skuda

not before, they have included in the last AUR package version because of this problem, i have not tried running the .run directly downloaded from Oracle but it seems it is being packaged without this file in other distro (i have read about this problem with other distros too).

comment:29 Changed 3 years ago by michael

Given that we don't have any control over how Arch Linux do their packaging this seems to me their bug not ours, and I think we can consider this closed.

comment:30 Changed 3 years ago by skuda

Yes, i have not tested if the official installer .run creates this file but i suppose you know it.

comment:31 Changed 3 years ago by silencekeeper

  • Status changed from closed to reopened
  • Resolution fixed deleted

Same problem with Amicon vpnldr on ubuntu 10.10 with VirtualBox 4.1.4, VirtualBox 4.0.12 and VirtualBox 4.0.4. On the another PC with ubuntu 10.10 and VirtualBox 4.0.4 everything is ok.

comment:32 Changed 3 years ago by michael

silencekeeper: could you please post the output of the following commands:

$ groups
$ VBoxManage list usbhost
$ ls -Rl /dev/vboxusb

comment:33 Changed 3 years ago by brihuega

My problem has gone since I installed VBox 4.1.4 (Linux 64). But the hardware has changed and also the Linux Kernel upgraded to 3.0. So I don't know whats the point on it.

comment:34 Changed 3 years ago by silencekeeper

$groups

root

$ vboxmanage list usbhost

UUID:               cc22ca5b-99fa-48ab-92ea-dae3edad5128
VendorId:           0x0458 (0458)
ProductId:          0x003a (003A)
Revision:           1.0 (0100)
Manufacturer:       Genius
Product:            Optical Mouse
Address:            sysfs:/sys/devices/pci0000:00/0000:00:04.0/usb1/1-1//device:/dev/vboxusb/001/007
Current State:      Busy

UUID:               31c89f68-01dc-45db-9f91-f744a3837dbf
VendorId:           0x04f2 (04F2)
ProductId:          0x0402 (0402)
Revision:           1.101 (01101)
Manufacturer:       Chicony
Product:            USB Keyboard
Address:            sysfs:/sys/devices/pci0000:00/0000:00:04.0/usb1/1-2//device:/dev/vboxusb/001/003
Current State:      Busy

UUID:               18eb91ca-ba51-4e16-96ef-6874b94a5f75
VendorId:           0xa420 (A420)
ProductId:          0x5420 (5420)
Revision:           1.0 (0100)
Manufacturer:       AMICON
Product:            VPNLDR 1.5
Address:            sysfs:/sys/devices/pci0000:00/0000:00:06.0/usb2/2-2//device:/dev/vboxusb/002/003
Current State:      Held

$ ls -Rl /dev/vboxusb

/dev/vboxusb/:
Total 0
drwxr-x--- 2 root vboxusers 80 2011-10-12 17:41 001
drwxr-x--- 2 root vboxusers 60 2011-10-12 17:40 002

/dev/vboxusb/001:
Total 0
crw-rw---- 1 root vboxusers 189, 2 2011-10-12 17:32 003
crw-rw---- 1 root vboxusers 189, 6 2011-10-12 17:41 007

/dev/vboxusb/002:
Total 0
crw-rw---- 1 root vboxusers 189, 130 2011-10-12 17:40 003

comment:35 Changed 3 years ago by silencekeeper

I cloned host system by Acronis TrueImage to the another PC and Amicon VPN Key works fine on it.

comment:36 Changed 3 years ago by michael

Are you running VirtualBox as root? If not you should be a member of the group "vboxusers" to use USB devices. Although of course you should get a warning about this.

comment:37 Changed 3 years ago by silencekeeper

Yes, i running VirtualBox as root.

comment:38 Changed 3 years ago by silencekeeper

I can give SSH access to this PC if it could help to resolve the problem.

comment:39 Changed 2 years ago by u-foka

This still happens on Ubuntu 11.10 with VirtualBox 4.1.8-75467~Ubuntu~oneiric (from the virtualbox.org repo) Any ideas why this happens? Any workarounds?

comment:40 Changed 2 years ago by brihuega

It was solved for me on ArchLinux 64 bits. Someone can tell me how to disable the email subscription from this ticket?

comment:41 Changed 2 years ago by skuda

Same as brihuega, i have not problem anymore in ArchLinux 64 bits.

comment:42 Changed 2 years ago by frank

Unsubscribing from a bug is not possible. I assume you are using the generic package on ArchLinux while u-foka is using the Oneiric package.

u-foka, please provide the same information Michael was requesting above.

comment:43 Changed 2 years ago by brihuega

It's funny. I can divorce from my wife but not from this ticket :-)) He and his bug happy ever after :-)

comment:44 Changed 22 months ago by Thiago Almeida

Same problem in Ubuntu 10.04 64bit and Ubuntu 10.10 64bit using VirtualBox 4.1.18, and Gentoo (64bit) using VirtualBox 4.1.12 with usb hardlock proteq compact-500.
Log of Gentoo:

01:00:19.092 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR)}, preserve=false
VBoxManage list usbhost
UUID:               1d5123f0-9364-4376-91eb-d00713aaf666
VendorId:           0x0e40 (0E40)
ProductId:          0x0001 (0001)
Revision:           0.1 (0001)
Manufacturer:       PROTEQ ltda 
Product:            PROTEQ USB
Address:            sysfs:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2//device:/dev/vboxusb/002/024
Current State:      Held

comment:45 Changed 16 months ago by thorstenhirsch

Same problem here. I've got 2 pretty similar devices, both are linux character devices. One works fine, the other one is affected by the bug covered here.

1.) The working device, a modem-like device in a mobile phone that is handled by the linux cdc_acm module ((and appears in VirtualBox's usb device list):

Dec 27 19:51:57 bender kernel: [ 7093.680091] usb 2-1: new high-speed USB device number 12 using ehci_hcd
Dec 27 19:51:57 bender kernel: [ 7093.812891] usb 2-1: New USB device found, idVendor=0955, idProduct=7f20
Dec 27 19:51:57 bender kernel: [ 7093.812902] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Dec 27 19:51:57 bender kernel: [ 7093.812909] usb 2-1: Product: APX
Dec 27 19:51:57 bender kernel: [ 7093.812915] usb 2-1: Manufacturer: NVIDIA Corp.
/dev$ ls -lR vbox*
crwxrwxrwx 1 root root      10, 54 Dec 27 17:54 vboxdrv

vboxusb:
total 0
drwxrwxrw- 2 root vboxusers 60 Dec 27 17:54 001
drwxrwxrw- 2 root vboxusers 80 Dec 27 21:22 002

vboxusb/001:
total 0
crw-rw---- 1 root vboxusers 189, 1 Dec 27 17:54 002

vboxusb/002:
total 0
crw-rw---- 1 root vboxusers 189, 129 Dec 27 17:54 002
crw-rw---- 1 root vboxusers 189, 143 Dec 27 21:22 016

Activating this device in VirtualBox's usb device list lets the guest system (Win7) install an appropriate driver. Everything works fine.

2.) The erroneous device, also a modem-like device in a mobile phone, but it is not handled by any linux module; it is just passed through in a raw way (and appears in VirtualBox's usb device list!):

[14201.730853] usb 2-1: USB disconnect, device number 16
[14208.640136] usb 2-1: new high-speed USB device number 17 using ehci_hcd
[14208.773056] usb 2-1: New USB device found, idVendor=0955, idProduct=7f20
[14208.773067] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[14208.773074] usb 2-1: Product: APX
[14208.773080] usb 2-1: Manufacturer: NVIDIA Corp.
$ ls -lR vbox*
crwxrwxrwx 1 root root      10, 54 Dec 27 17:54 vboxdrv

vboxusb:
total 0
drwxrwxrw- 2 root vboxusers 60 Dec 27 17:54 001
drwxrwxrw- 2 root vboxusers 80 Dec 27 21:50 002

vboxusb/001:
total 0
crw-rw---- 1 root vboxusers 189, 1 Dec 27 17:54 002

vboxusb/002:
total 0
crw-rw---- 1 root vboxusers 189, 129 Dec 27 17:54 002
crw-rw---- 1 root vboxusers 189, 144 Dec 27 21:50 017

Activating this device in VirtualBox's usb device list leads to the error messages covered in this bug report (VERR_READ_ERROR and NS_ERROR_FAILURE).

Host system: Ubuntu 12.10 x64 with vt-x Guest system: Windows 7 x64 VirtualBox version: 4.2.6 with proprietary USB 2.0 package; GuestAdditions 4.2.6 installed.

comment:46 Changed 16 months ago by thorstenhirsch

Reproduced this issue on another host/guest combination:

Host system: Ubuntu 12.10 x64 withOUT vt-x Guest system: Windows 7 x86 (32bit) VirtualBox version: 4.2.6 with proprietary USB 2.0 package; GuestAdditions 4.2.6 installed.

Here the APX device was in the status "unavailable" (VBoxManage list usbhost) until I added a filter. There's also a filter for the device on the other installation, so I guess adding a filter for the APX device is mandatory to reproduce the issue.

comment:47 Changed 7 months ago by AlwaysLearning

fyi, ticket #9645 would seem to be a duplicate of this issue.

I get this error with an iPhone 3GS as well:

Failed to attach the USB device Apple Inc. iPhone [0210] to the virtual machine Dell-Inspiron-8600. Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR). Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

In my case it's linked to the Passthrough option on the CD-DVD driver in Settings/Storage:

  1. Turn off Passthrough, boot guest, start iTunes, connect the iPhone to the host. iTunes connects OK and can backup/restore/sync, but cannot detect/use audio CDs so I cannot import CDs.
  2. Turn on Passthrough, boot guest, start iTunes: I can import audio CDs, but I get the above error message when I connect the iPhone to the host.

Thankfully I don't often need to import audio CDs. I haven't experimented with other USB devices (this guest's sole purpose in life is to run iTunes for the iPhone).

Host details...

$ uname -a

Linux foo 3.2.0-54-generic-pae #82-Ubuntu SMP Tue Sep 10 20:29:22 UTC 2013 i686 i686 i386 GNU/Linux

$ lsb_release

LSB Version:	core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch

$ VBoxManage --version

4.2.18r88780

(4.2.18-88780~Ubuntu~precise, as installed from  http://download.virtualbox.org/virtualbox/debian precise contrib)

$ groups

user adm dialout cdrom plugdev lpadmin admin sambashare vboxusers powermate subversion

$ lsusb | grep Apple

Bus 001 Device 012: ID 05ac:1294 Apple, Inc. iPhone 3GS

$ VBoxManage list usbhost

UUID:               8cc4b6a4-db1c-4b33-8d54-aa7883d0fd04
VendorId:           0x05ac (05AC)
ProductId:          0x1294 (1294)
Revision:           2.16 (0216)
Port:               0
USB version/speed:  2/2
Manufacturer:       Apple Inc.
Product:            iPhone
SerialNumber:       .....
Address:            sysfs:/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-1//device:/dev/vboxusb/001/012
Current State:      Captured

Guest details:

Windows XP Professional SP3
VBoxControl --version => 4.2.18r8870
iTunes v11.0.5.5

comment:48 Changed 3 months ago by pavkaml

The some problem on FC20 with guest Windows 7 Pro 64bit For some devices works, for APX device this error.

comment:49 Changed 3 weeks ago by ha-tech

It could be reproduced in my environment.

When I plug-in an ATM card-read, EasyATM COMBO which maked by "TODOS eCode", it will pop message as below. My environment is Vbox 4.3.10 installed on Ubuntu 12.04.

Failed to attach the USB device Todos Data System AB Todos eCode Connectable [0100] to the virtual machine windows_xp_2.
Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR).

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

In VBox.log:

 00:11:34.655750 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={8ab7c520-2442-4b66-8d74-4ff1e195d2b6} aComponent={Console} aText={Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR)}, preserve=false

$ groups

alextu adm cdrom sudo dip plugdev lpadmin sambashare vboxusers

$ vboxmanage list usbhost

Host USB Devices:

UUID:               8f26abf5-7d00-4215-9d41-e34529c1d567
VendorId:           0x046d (046D)
ProductId:          0xc019 (C019)
Revision:           67.1 (6701)
Port:               2
USB version/speed:  2/1
Manufacturer:       Logitech
Product:            USB Optical Mouse
Address:            sysfs:/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-5/2-5.3//device:/dev/vboxusb/002/005
Current State:      Busy

UUID:               987e55ed-c62e-40ac-b64c-94a81db101db
VendorId:           0x04d9 (04D9)
ProductId:          0x1603 (1603)
Revision:           3.16 (0316)
Port:               0
USB version/speed:  1/1
Manufacturer:        
Product:            USB Keyboard
Address:            sysfs:/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-5/2-5.1//device:/dev/vboxusb/002/004
Current State:      Busy

UUID:               8b61d943-3ac5-46d6-9b58-ae5402dc70e0
VendorId:           0x0b0c (0B0C)
ProductId:          0x000e (000E)
Revision:           1.0 (0100)
Port:               0
USB version/speed:  1/1
Manufacturer:       Todos Data System AB
Product:            Todos eCode Connectable
Address:            sysfs:/sys/devices/pci0000:00/0000:00:1d.0/usb4/4-1//device:/dev/vboxusb/004/008
Current State:      Held

UUID:               7f38ac7e-73c3-4181-ad28-6ecb79d70803
VendorId:           0x1130 (1130)
ProductId:          0xf211 (F211)
Revision:           1.11 (0111)
Port:               1
USB version/speed:  1/1
Product:            USB  AUDIO  
Address:            sysfs:/sys/devices/pci0000:00/0000:00:1d.0/usb4/4-2//device:/dev/vboxusb/004/002
Current State:      Busy


$ ls -Rl /dev/vboxusb

/dev/vboxusb:
total 0
drwxr-x--- 2 root vboxusers 80 Mar 30 23:44 002
drwxr-x--- 2 root vboxusers 80 Mar 31 00:09 004

/dev/vboxusb/002:
total 0
crw-rw---- 1 root vboxusers 189, 131 Mar 30 23:44 004
crw-rw---- 1 root vboxusers 189, 132 Mar 30 23:44 005

/dev/vboxusb/004:
total 0
crw-rw---- 1 root vboxusers 189, 385 Mar 30 23:44 002
crw-rw---- 1 root vboxusers 189, 391 Mar 31 00:09 008

I have add my account to be a member of the group "vboxusers".

https://lh3.googleusercontent.com/rIJI8HH4y147K1OJ1_x1d4H3SB-OpCKTVNiXDukkJDM=w209-h162-p-no

BTW, this issue still could be reproduced in root account($sudo virtualbox).

Last edited 10 days ago by ha-tech (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use