VirtualBox

Ticket #5164 (closed defect: fixed)

Opened 5 years ago

Last modified 22 months ago

Shutting down SCO Openserver 5.0.7 triggers Guru Meditation -> fixed in SVN

Reported by: cyruspy Owned by:
Priority: minor Component: VMM
Version: VirtualBox 4.1.16 Keywords: sco openserver poweroff guru meditation
Cc: Guest type: other
Host type: other

Description

Shutting down SCO Openserver 5.0.7 or rebooting it, triggers Guru Meditation

Attachments

VBox.log Download (123.1 KB) - added by cyruspy 5 years ago.
Log from poweroff attempt
VBox.2.log Download (118.6 KB) - added by cyruspy 5 years ago.
Reboot attempt
reboot-VBox.log Download (130.2 KB) - added by multitalents 4 years ago.
reboot-VBox.png Download (938 bytes) - added by multitalents 4 years ago.
VBox.3.log Download (397.4 KB) - added by jag-7777 23 months ago.
problem returned?
VBox.png Download (953 bytes) - added by jag-7777 23 months ago.
problem returned?

Change History

Changed 5 years ago by cyruspy

Log from poweroff attempt

Changed 5 years ago by cyruspy

Reboot attempt

comment:2 Changed 5 years ago by sandervl73

Fixed one problem during the end of the installation phase (same guru).

comment:3 Changed 5 years ago by sandervl73

  • Summary changed from Shutting down SCO Openserver 5.0.7 triggers Guru Meditation to Shutting down SCO Openserver 5.0.7 triggers Guru Meditation -> fixed in SVN/3.0.10

I can shut it down properly, but reboot does nothing it seems. Anyway, the guru is gone.

comment:4 Changed 5 years ago by cyruspy

Good!, does it change anything if you run "make pm", that seems to enable APM support. ACPI is not supported as far as I know.

As a workaround I edited /etc/conf/pack.d/uapm/space.c in the guest, maybe checking that file helps somehow...

Ref:  http://cyruspy.wordpress.com/2009/10/08/running-sco-openserver-5-0-7-in-virtualbox/

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Changed 4 years ago by multitalents

Changed 4 years ago by multitalents

comment:6 Changed 4 years ago by multitalents

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am currently running Virtualbox 3.1.12 on an OpenSolaris svn_127 host and I still get a Guru Meditation when rebooting my OpenServer 5.0.7 vm. Log and screen capture attached.

P.S. Same problem on rebooting UnixWare 7.x and OpenServer 6

comment:7 Changed 4 years ago by multitalents

Oops. Sorry that was Virtualbox 3.1.2

comment:8 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Different guru. Possibly Solaris host related. Please open a new ticket.

Changed 23 months ago by jag-7777

problem returned?

Changed 23 months ago by jag-7777

problem returned?

comment:9 Changed 23 months ago by jag-7777

Has this become a problem again in version 4.1.16? I just built a SCO 507 VM and have this exact problem. It looks like it was fixed, but maybe returned. If I do a shutdown, it goes to safe to power off and I can end the VM fine. However, pressing a key to reboot or running the reboot command (or init 6) the system will shutdown fine, but Guru the second after. Attaching log and png files.

comment:10 Changed 23 months ago by jag-7777

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:11 Changed 23 months ago by klaus

How reproducible is this? We're hunting a similar bug for quite a while now, but it's far from reproducible enough to make progress.

comment:12 Changed 23 months ago by jag-7777

Very much so, it happens every time I restart or init 6.

comment:13 Changed 23 months ago by michaln

  • Status changed from reopened to closed
  • Component changed from other to VMM
  • Summary changed from Shutting down SCO Openserver 5.0.7 triggers Guru Meditation -> fixed in SVN/3.0.10 to Shutting down SCO Openserver 5.0.7 triggers Guru Meditation -> fixed in SVN
  • Priority changed from major to minor
  • Version changed from VirtualBox 3.0.8 to VirtualBox 4.1.16
  • Resolution set to fixed

The problem with a guru meditation (or possibly a hang) after letting SCO Openserver reboot itself is now fixed in svn and will be included in the next update.

As far as I can tell, the issue has been there for a very long time.

comment:14 Changed 22 months ago by frank

Fix is part of VBox 4.1.18.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use