VirtualBox

Ticket #5140 (new defect)

Opened 5 years ago

Last modified 4 years ago

Solaris guests unusably slow on 32-bit WinXP host

Reported by: rasta Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: Solaris
Host type: Windows

Description

HOST:

WinXPsp3 32-bit with VT (dual quad-core Intel Xeon E5345 processors) 4 GB RAM NVIDIA Quadro FX 3500 video card with 256 MB VRAM

GUEST:

Solaris 10 u7 1500 MB RAM assigned 128 MB VRAM 3.0.8 guest additions installed IOAPIC, ACPI, PAE, VT-x enabled

32- and 64-bit Solaris guests are too slow to use. Windowing system of guest and host are unusable while guest is running. Problem may lie with Xorg implementation in guest additions? Major regression from 3.0.4. 64-bit guest will boot, but login takes >2 minutes and guest is unusable. Could not login to 32-bit guest using 1 processor; just hung. Could log in to 32-bit guest with 4 processors, but guest was unusable. Using JDS for guest. Could not start Firefox in any Solaris guest.

Attachments

Solaris 10 u7-2009-10-06-14-43-51_32-bit-guest.log Download (56.5 KB) - added by rasta 5 years ago.
log of unusable 32-bit Solaris guest
Solaris 10 u7-2009-10-06-15-34-45_64-bit-guest.log Download (61.1 KB) - added by rasta 5 years ago.
log of unusable 64-bit Solaris guest

Change History

Changed 5 years ago by rasta

log of unusable 32-bit Solaris guest

comment:1 Changed 5 years ago by rasta

Are Solaris guests tested on Windows hosts by Sun? If so, what are the recommended optimal guest/host settings for doing so with my system configuration?

comment:2 Changed 5 years ago by rasta

Guest behavior is similar to that described in bug #4411.

comment:3 Changed 5 years ago by rasta

Very strange things are going on with USB. I had two USB 2 devices defined in the VM control GUI. When the guest is running, the VM sees another device (a USB interface to a UPS), and I cannot access the UPS using the host. Is there a new USB-related problem?

Changed 5 years ago by rasta

log of unusable 64-bit Solaris guest

comment:4 Changed 5 years ago by sandervl73

Well, first things first. Your Xeon doesn't have a specific optimization for APIC accesses, so a 32 bits Solaris guest is going to be slow if you enable the IO-APIC. That's nothing new. Try with the IO-APIC disabled, which implies one VCPU.

Running 64 bits guests on 32 hosts is not ideal either. Last time I checked it was ok on my Core i7.

comment:5 Changed 5 years ago by rasta

I'll try that, but enabling IO-APIC never presented a problem before with 32-bit Solaris guests. In addition, even 64-bit Solaris guests would boot and run reasonably OK with Vbox versions 3.0.4 and earlier (although they were very unstable). The behavior with 3.0.8 for ALL Solaris guests on 32-bit hosts is brand new, and renders Solaris guests of any stripe mostly inoperable.

I just disabled IO-APIC, and a 32-bit guest was so slow that it renders my mouse and keyboard nearly functionless on my guest AND HOST. All brand new in 3.0.8. What a waste of time for me, as Vbox has been for the last 6 months.

comment:6 Changed 5 years ago by rasta

To be clear, 32-bit guests with IO-APIC enabled worked fine with vbox 3.0.6 and earlier.

comment:7 Changed 5 years ago by sandervl73

It works fine here. If you're going to start complaining that way, then I don't really feel like investing my time in free support. Either we stay civilized or call the whole thing off.

comment:8 Changed 5 years ago by rasta

I greatly appreciate your support, and I am sorry to "vent" a little. I'm just speaking the truth, and being very sensitive about it, given how I really feel. Besides changing to a 64-bit host, what do you suggest I do to document the 3.0.8 problem? Were the logs I supplied helpful?

I tried disabling the USB controller for the guest and that did not help.

comment:9 Changed 5 years ago by rasta

Just to check, I went back to 3.0.6 and a 32-bit guest again runs normally (without IO-APIC this time - thanks for the reminder about that).

I'll reinstall 3.0.8 if you can think of a way for me to demonstrate the problem to you.

You mentioned that 64-bit guests on 32-bit hosts are not ideal, but the regression in 3.0.6 (that I first documented in bug #4947) involved just such an environment, so I had hoped that 3.0.8 would allow 64-bit guests to not just boot but run better and with more stability on 32-bit hosts. That is certainly not what I have encountered thus far, but the new problem also involves 32-bit guests.

comment:10 Changed 5 years ago by sandervl73

I'll have a closer look and report back later today.

comment:11 Changed 5 years ago by sandervl73

Just to make another thing clear: I do appreciate the amount of effort you put into helping me trace down these issues. I can understand your frustration, but let's put that aside and just fix the issue.

comment:12 Changed 5 years ago by sandervl73

Tried the following:

- host: Vista 32
- guest: Solaris 10u5, 1024 MB, pcnet, usb & audio enabled
- guest additions 3.0.8

No performance problems here.

comment:13 Changed 5 years ago by sandervl73

Installed Solaris 10u7. No problems with 1500 MB ram and 128 mb vram either. Anything special installed in your VM?

By the way, 128 mb vram is overkill. You are just wasting memory and gain nothing. 16 or 32 mb is more than sufficient.

comment:14 Changed 5 years ago by rasta

Thank you for testing! Your results suggest that there may be something wrong with my installation of 3.0.8. I'll try reinstalling it today. My Sol 10 u7 is fully patched, and that includes a recent Xorg-related patch. I hope that that patch did not mess anything up vis-a-vis the Xorg implementation in the guest additions. Is your s10 u7 fully patched?

I'll also reduce the guest VRAM - thanks for the suggestion!!!!!!!

I have been installing new versions of vbox over old versions, without uninstalling the old version first. That has worked before. I typically do not reboot the host after installing a new vbox, as I am not asked by the installer to do so. Does all that sit well with you, or do you recommend a different install sequence?

comment:15 Changed 5 years ago by sandervl73

I installed a bare S10u7 from the release DVD. Perhaps the patch matters or the fact that my systems support the APIC optimization. I'll disable it and see if that makes things much worse.

Tried on an Intel Quad-Core as well. Performance is still good. (S10u5)

comment:16 Changed 5 years ago by sandervl73

Upgrading VirtualBox installations is fine. No need to uninstall and reinstall.

comment:17 Changed 5 years ago by sandervl73

The APIC optimization doesn't make any difference. Will try to update U7.

comment:18 Changed 5 years ago by rasta

I was mistaken about the Xorg patch. There were recent patches for the new javaSE (update 21), GNOME libtiff, patch behavior, XML/XSLT libs, GNOME libs (120461-16), and GNOME Java help. However, the new patch issue is most likely moot:

I re-installed 3.0.8, and was able to login to a 32-bit guest (no APIC), but performance was very poor. After removing 3.0.6 GA, logoff/logon hung and corrupted guest boot archive, so I had to revert to old snapshot (not having new patches) and reboot. 32-bit guest performance still horrible, without the new patches. Re-installed 3.0.8 GA, a rebooted: no change. A new login has completely hung the guest again.

However, I would try patching your u7 guest up to current level, including kernels.

Something is very wrong, in that the host is being severely affected by vbox (USB, windowing, mouse). There is something in 3.0.8 that is affecting my host and guest at a fundamental level. Sound in the guest (osl guest driver, Windows DirectSound host driver, ICH AC97 controller) is non-functional, and very choppy and interrupted on login (abnormal). Please let me know how I can demonstrate this to you (other logs?).

comment:19 Changed 5 years ago by rasta

I disabled audio support for the guest, and everything seems to be running better for a 32-bit guest. Were any changes made regarding audio support in 3.0.8? There was a Sound Blaster-related fix for bug #5042.

comment:20 Changed 5 years ago by rasta

From 3.0.8 changelog:

VMM: fixed release assertion during state restore when using the Sound Blaster 16 emulation (bug #5042)

comment:21 Changed 5 years ago by rasta

Oops, I meant oss guest audio driver, not osl:

 http://www.opensound.com/download.cgi

comment:22 Changed 5 years ago by rasta

I think that audio support is the source of the problem. A 64-bit guest is running quite well now with guest audio support disabled.

comment:23 Changed 5 years ago by rasta

The guest Xorg process is still constant at 0.5-3% load, which is abnormal, (~1/2 of cpu load in gnome-perfmeter). Overall 64-bit guest performance is quite good, though, without sound.

comment:24 Changed 5 years ago by frank

The SoundBlaster fix shouldn't be related to your problem. And you have the AC97 controller enabled, correct?

comment:25 Changed 5 years ago by sandervl73

There have been no changes in audio support afaik. I have to try that here.

Performance is back to the 3.0.4 level or not quite?

comment:26 Changed 5 years ago by sandervl73

I've enabled audio and installed the opensound driver. No abnormal behaviour here.

comment:27 Changed 5 years ago by rasta

Yes, Frank, Windows DirectSound host driver, ICH AC97 controller. Without sound, the guests appear to nearly back to 3.0.4 levels, but the 64-bit guest has the constant Xorg activity, which was NOT the case in 3.0.4. I will check on 64-bit guest stability today, as I left it running overnight installing patches. Hopefully no hangs! Can either of you suggest any way for me to tweak the guest configuration (drivers/controllers, VM settings, etc.) to either get audio back and/or get info/logs that you can use to diagnose the problem I am having? Thank you both for your support!

comment:28 Changed 5 years ago by rasta

No hangs for the 64-bit guest overnight! That suggests that 3.0.8 is improved over 3.0.4 in 64-bit guest stability.

comment:29 Changed 5 years ago by rasta

I think now that the problem, which is unbelievably severe for guest and host (hangs, can't move mouse at all), is related, at least in part, to some conflict between the oss driver, standard Solaris audio driver, and/or vbox audio drivers.

I installed the latest version of oss after removing the older version. The slowness/hanging problem for guest and host is now sometimes absent after login. However, if I run ossdetect to get the oss driver running, the problem returns.

What exact steps did you perform to get your guest to recognize the oss driver and get JDS to handle audio normally?

comment:30 Changed 5 years ago by rasta

Were any changes made to the Solaris guest additions between 3.0.6 and .8?

comment:31 Changed 5 years ago by rasta

Repairing the vbox installation and removing oss entirely made no difference.

USB issues may be involved, and have presented major issues for vbox in the past. I defined two USB 2 hard drives in the VM configuration, and when the guest is booted and running, my UPS is available under USB devices, but not my two drives. Any suggestions?

comment:32 Changed 5 years ago by rasta

After much testing, disabling guest audio support in the main vbox GUI is the only way to get Solaris guests to function on my system. Have you tested 3.0.8 with a fully patched Sol 10 u7 guest yet?

comment:33 Changed 5 years ago by rasta

Try enabling both "Sound Server setup" AND "Sounds for events" in JDS desktop sound prefs, and then logoff/logon (also try rebooting guest). I found that disabling "sounds for events" resulted in normal 64-bit guest operation, with audio support obviously enabled for the guest in the VM settings. I'm still testing, however. Having both these JDS settings checked presented no problem in previous vbox versions.

comment:34 Changed 5 years ago by sandervl73

There have been no related changes to the Solaris additions. I simply installed the OSS drivers from the link you gave above and didn't observe any slowness.

I haven't tried a fully patched U7, but can try U9 later. It's a bit hard to understand what's going on without being able to reproduce it locally.

comment:35 Changed 5 years ago by rasta

Please try the sound server/events JDS prefs change I mentioned above. Both those prefs were enabled when I experienced the problem. The problem is unrelated to oss, I now believe. The question is, why did those settings kill my guests (and host) in 3.0.8 and not previously? Probably updating u7 is also required to reproduce.

Even with "sounds for events" disabled, logging in is much slower than before, and is in part probably related to the Solaris sound server initiation. But the slowness and guest/host windowing hangs are gone.

comment:36 Changed 4 years ago by rasta

I upgraded to Sol 10 u8 and patched it. Installed oss 4.2 driver. 64-bit guest will function nominally as long as "sounds for events" is disabled. However, although osstest will work, Solaris/JDS will not recognize the oss drivers, so normal desktop audio will not work. If ossdetect is run, Solaris/JDS does recognize the audio driver after logoff/logon, and desktop audio will work, but the horrible system slowness for guest and host resumes, with varying degrees of severity. Without oss installed, the same problem occurs using standard Solaris audio drivers.

comment:37 Changed 4 years ago by rasta

In short, playing sounds can kill a Solaris 10 guest. Regardless of audio driver, when an app plays a sound, the guest grinds to a near halt, USB connections drop, etc. I tried re-installing all sound-related Solaris packages from DVD, that did not help (I thought that install/uninstall of oss could have fried them). Do sounds (e.g. from a mp3 or mpg, web video) play ok on your Solaris guest using vobx 3.0.8? That should be very easy for you to test.

comment:38 Changed 4 years ago by rasta

A similar problem has been found on a WinXP host with Linux guests:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=24392&p=108318#p108318

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use