VirtualBox

Ticket #5128 (closed task: worksforme)

Opened 5 years ago

Last modified 4 years ago

Unable to fix NS_ERROR_FACTORY_NOT_REGISTERED error

Reported by: Ptolemey Owned by:
Priority: minor Component: other
Version: VirtualBox 2.2.4 Keywords: Failed to launch
Cc: Guest type: other
Host type: Linux

Description

Problem: when I launch VirtualBox command I'm immediately getting this error: NS_ERROR_FACTORY_NOT_REGISTERED.

Currently I've got Ubuntu 9.04, virtualbox-ose 2.2.4 installed from the debian package downloaded from virtualbox.org.

The history of my efforts to launch the VirtualBox looks like this: initially I installed virtualbox-ose 2.1.4 from ubuntu repository, then I tried virtualbox-3.0, then tried to compile VirtualBox from source with hardening DISABLED, after which I purged the virtualbox and installed virtualbox-ose 2.2.4. The bottom line is that the error remained the same for all these versions I tried. I was launching the VirtualBox under my user (which is included in vboxusers group) and under the root with the same error resulting.

I've been trying various solutions presented in the tickets dealing with this specific error but none of them seems to be working for me:

  1. I checked the permissions of /tmp dir as suggested in tickets 2335,3568, they are correct:

/tmp drwxrwxrwt

  1. Checked the permissions of /tmp/.vbox-<user>-ipc:

/tmp/.vbox-<user>-ipc drwx------ 2 <user> <user>

  1. I created soft links to the library files as suggested in the ticket 3672:

find /usr/lib/virtualbox -maxdepth 1 -name '*.so' -exec ln -s \{} /usr/lib/virtualbox/components/ \;

The forum did not help either, so I decided to create a new ticket. I could not find VBox.log file on my machine to attach it.

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Please reopen if still relevant.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use