VirtualBox

Ticket #512 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Display bug with DetaolB (linux distribution) => Fixed in 1.5.4

Reported by: cmichon Owned by: frank
Priority: critical Component: other
Version: VirtualBox 1.4.0 Keywords: display garbage
Cc: Guest type: other
Host type: other

Description

I'm the maintainer of DetaolB ( http://detaolb.sf.net)

It's a linux distribution, using framebuffer mode vesafb-tng. Inside, Xfree can be used in framebuffer mode, which means that once you've booted succesfully in fb mode, Xfree should work out of the box.

It's the case using qemu, and vmplayer. But VirtualBox gives me a blank screen. This was reported by a beta user.

How to reproduce this:

  • download detaolb_v04.iso (link is in detaolb.sf.net)
  • setup a std linux 2.6 machine (128M ram, no hdd)
  • boot it on cdrom
  • log in as root, no password
  • type in "xinit"

I believe this is a bug in the way you handle the graphics (2 other virtualizers are ok). Please let me know if this is of interest to you for your next release by email at christian.michon@…

Thanks

Christian MICHON

Change History

comment:1 Changed 7 years ago by sandervl73

  • Priority changed from blocker to critical

comment:2 Changed 7 years ago by sandervl73

Please wait for the next release (due out very soon). If it still happens there, then we'll have a look. Thanks.

comment:3 Changed 7 years ago by cmichon

Please wait for the next release (due out very soon). If it still happens there, then we'll have a look. Thanks.

-- Ticket URL: < http://www.virtualbox.org/ticket/512#comment:2> VirtualBox < http://www.virtualbox.org/> InnoTek VirtualBox Open Source Edition

bug #512 is still happening with virtualbox 1.5.0

my host: windows XP sp2 my guest: detaolb v0.6 ( http://detaolb.sf.net)

when the guests starts, it boots in framebuffer (working). a simple "cat /dev/urandom > /dev/fb0" works too. a simple "cat < /dev/mouse0" works too.

but when Xfbdev tries to access the screen (using xinit), it freezes the whole system. this works well with other virtualizers, so I guess the problem is mostly on vbox side.

comment:4 Changed 6 years ago by sandervl73

  • Cc christian.michon@… removed

comment:5 Changed 6 years ago by frank

  • Owner set to frank
  • Status changed from new to assigned
  • Summary changed from Display bug with DetaolB (linux distribution) to Display bug with DetaolB (linux distribution) => Fixed in 1.5.4

detaolB 0.4 as well as detalOB 0.6 run fine on VBox 1.5.4 which is released soon.

comment:6 Changed 6 years ago by frank

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use