VirtualBox

Ticket #5112 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

Beta fails to install on Fedora12 Alpha

Reported by: lyon Owned by:
Priority: minor Component: installer
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hi All, Because of the libcrypto.so.8 dependency problem with Fedora 12 alpha, I have tried experimenting with an installation of Beta 3.0.6.

However, this does not seem to go very well, for me; sudo sh sudo sh VirtualBox-3.0.6_BETA1-51790-Linux_amd64.run\?e=1254654137\&h=59256c75e71b80274f6a71a8613d1fc3 [sudo] password for lyon: Verifying archive integrity... All good. Uncompressing VirtualBox for Linux installation......... VirtualBox Version 3.0.6_BETA1 r51790 (2009-09-01T17:21:44Z) installer hplaptop.docjava{lyon}230: Installing VirtualBox to /opt/VirtualBox bzip2: Can't open input file VirtualBox.tar.bz2: No such file or directory. tar: This does not look like a tar archive tar: Exiting with failure status due to previous errors Error installing VirtualBox. Installation aborted

Change History

comment:1 Changed 5 years ago by lyon

Hi All,
It appears I have made a silly error and downloaded the wrong beta version.
The new beta works, for installation, however does not start:

 vbox

Username: lyon
Password: 

Connecting to 'localhost:20012'...
vbox: can't connect to 'localhost:20012'.
hplaptop.docjava{lyon}246: vbox -version

vbox version 2.0.0BETA5 (17-NOV-98)

----
cat /var/log/vbox-install.log

VirtualBox 3.0.6_BETA1 r51790 installer, built 2009-09-01T17:21:44Z.

Testing system setup...
System setup appears correct.

Installing VirtualBox to /opt/VirtualBox

Error running "bzip2 -d -c VirtualBox.tar.bz2 | tar -tf - > /etc/vbox/filelist".

I bet this is a more common error.

comment:2 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Why not try the non-beta version of 3.0.6, that was released a month ago? And install the fedora 11 version instead of the generic one.

Version 3.0.8 will get a fedora 12 build, so you may want to wait a few days.

comment:3 Changed 5 years ago by lyon

  • Status changed from closed to reopened
  • Resolution worksforme deleted

The non-beta version of VBOX will not install, because of dependencies:

error: Failed dependencies:
	libcrypto.so.8()(64bit) is needed by VirtualBox-3.0.6_52128_fedora11-1.x86_64

comment:4 Changed 5 years ago by frank

  • Priority changed from blocker to minor
  • Status changed from reopened to closed
  • Resolution set to fixed

There is already an inofficial F12 build of VBox 3.0.6 available at the download server. And, btw, the planned release date of F12 is 2009-11-10, so this defect is not a blocker in any case.

comment:5 Changed 5 years ago by lyon

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi All,

Based in the suggestion, I have installed Fedora 12 Alpha 3.0.6, as shown, below, but continue to get the same error. Am I doing something dumb?

And is this minor? Or a blocker? Basically, you can't start the program. Perhaps the fix is minor, but the effect is that of a blocker.


VirtualBox        x86_64        3.0.6_52128_fedora12-1          VirtualBox-3.0.6_52128_fedora12-1.x86_64.rpm?e=1254678672&h=37581086b5880581a3e2b8374d0e8d9a
                                                                           92 M

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total size: 92 M
Is this ok [y/N]: y
Downloading Packages:


Package VirtualBox-3.0.6_52128_fedora12-1.x86_64.rpm?e=1254678672&h=37581086b5880581a3e2b8374d0e8d9a is not signed
hplaptop.docjava{lyon}269: vbox

Username: lyon
Password: 

Connecting to 'localhost:20012'...
vbox: can't connect to 'localhost:20012'.
hplaptop.docjava{lyon}270: vbox -version

vbox version 2.0.0BETA5 (17-NOV-98)

comment:6 Changed 5 years ago by frank

It would have been nice if you had posted the commands you used to install the package. The package isn't trying to open any connection so I guess this is something of your setup which isn't obvious to me. What happens if you install the package with rpm -U VirtualBox-3.0.6_52128_fedora12-1.x86_64.rpm?

And regarding the priority: As I wrote, Fedora 12 isn't not released yet so we don't support this distribution yet therefore the priority is minor.

comment:7 Changed 5 years ago by lyon

Hi Frank,

Thank you for your prompt response.

sudo rpm -U VirtualBox-3.0.6_52128_fedora12-1.x86_64.rpm\?e=1254678672\&h=37581086b5880581a3e2b8374d0e8d9a
[sudo] password for lyon: 

Creating group 'vboxusers'. VM users must be member of that group!

No precompiled module for this kernel found -- trying to build one. Messages
emitted during module compilation will be logged to /var/log/vbox-install.log.

Success!

hplaptop.docjava{lyon}11: vbox

Username: lyon
Password: 

Connecting to 'localhost:20012'...
vbox: can't connect to 'localhost:20012'.

But I can now run it from the main console, so,
I am thinking the idea is that this has something to
do with the default display vbox uses.

comment:8 Changed 5 years ago by frank

I still don't fully understand the second part. Is hplaptop.docjava{lyon}11: your command line prompt and what is vbox supposed to be? The VirtualBox GUI is started by typing VirtualBox and it must not be started as root but as normal user. Also, VirtualBox uses the DISPLAY variable and it works on every other system I know. To me it seems like you are trying to start VirtualBox as root and probably your DISPLAY variable is wrong (try to start another X application from root and you will most likely observe the same error message).

comment:9 Changed 5 years ago by lyon

You are absolutely correct. My bad. VirtualBox is working great (and your support has been just outstanding).

Thanks!

  • Doug

comment:10 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

Thanks for the feedback, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use