VirtualBox

Ticket #5100 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

PCnet FAST-III not working in bridged mode while Intel desktop does

Reported by: Neighbour Owned by:
Component: network Version: VirtualBox 3.0.6
Keywords: bridge pcnet packetloss dhcp Cc:
Guest type: Linux Host type: Windows

Description

For some reason, when the VM's nic is bridged with the host's nic, packets destined for the VM are not picked up by the bridge interface. Test scenario: Capture for VM's MAC on dhcpserver, with the command: tcpdump -n -i eth1 -w vm_dhcpserver.cap ether src 08:00:27:24:BC:30 or ether dst 08:00:27:24:BC:30 or ether dst ff:ff:ff:ff:ff:ff Capture on the VM's host using wireshark, on the interface with which the VM is bridged. Capture the VM's nic using vboxmanage modifyvm --nictrace. Boot the VM, execute 'ifdown eth0' and then 'ifup eth0' and wait until the prompt returns. Save a screenshot of the VM window. Stop the captures and shut down the guest.

The above has been done for both situations (PCnet FAST-III and Intel Desktop adapter). As you can see, there are outgoing packets, which are responded to by the DHCPserver, but for some reason they never make it back to the VM. Strangely enough, the DHCPreplies are *not* picked up using wireshark on the host, but *are* picked up in the nictrace when using the Intel Desktop NIC in the guest.

Attachments

VBox.log Download (54.8 KB) - added by Neighbour 10 years ago.
Testrun with PCnet FAST-III adapter
Debian.xml Download (5.4 KB) - added by Neighbour 10 years ago.
VM configuration for PCnet FAST-III testsetup
vm_dhcpserver.cap Download (6.0 KB) - added by Neighbour 10 years ago.
Network Traffic Dump on DHCPserver for PCnet Fast-III testrun
vm_host-filtered.cap Download (7.0 KB) - added by Neighbour 10 years ago.
Host traffic dump for PCnet FAST-III testrun (filtered on VM-MAC and broadcast MAC)
vm_nictrace.cap Download (3.5 KB) - added by Neighbour 10 years ago.
VBox' nictrace on Guest for PCnet FAST-III testrun
Network_Issue_Screenshot.png Download (34.3 KB) - added by Neighbour 10 years ago.
Screenshot taken after PCnet Fast-III testrun
VBox.2.log Download (54.8 KB) - added by Neighbour 10 years ago.
Testrun with Intel Pro/1000 MT Desktop adapter
Debian.2.xml Download (5.6 KB) - added by Neighbour 10 years ago.
VM configuration for Intel Pro/1000 MT Desktop testsetup
vm_dhcpserver.2.cap Download (2.5 KB) - added by Neighbour 10 years ago.
Network Traffic Dump on DHCPserver for Intel Pro/1000 MT Desktop testrun
vm_host-filtered.2.cap Download (3.1 KB) - added by Neighbour 10 years ago.
Host traffic dump for Intel Pro/1000 MT Desktop testrun (filtered on VM-MAC and broadcast MAC)
nictrace.cap Download (4.8 KB) - added by Neighbour 10 years ago.
VBox' nictrace on Guest for Intel Pro/1000 MT Desktop testrun
Screenshot.png Download (33.0 KB) - added by Neighbour 10 years ago.
Screenshot taken after Intel Pro/1000 MT Desktop testrun

Change History

Changed 10 years ago by Neighbour

Testrun with PCnet FAST-III adapter

Changed 10 years ago by Neighbour

VM configuration for PCnet FAST-III testsetup

Changed 10 years ago by Neighbour

Network Traffic Dump on DHCPserver for PCnet Fast-III testrun

Changed 10 years ago by Neighbour

Host traffic dump for PCnet FAST-III testrun (filtered on VM-MAC and broadcast MAC)

Changed 10 years ago by Neighbour

VBox' nictrace on Guest for PCnet FAST-III testrun

Changed 10 years ago by Neighbour

Screenshot taken after PCnet Fast-III testrun

Changed 10 years ago by Neighbour

Testrun with Intel Pro/1000 MT Desktop adapter

Changed 10 years ago by Neighbour

VM configuration for Intel Pro/1000 MT Desktop testsetup

Changed 10 years ago by Neighbour

Network Traffic Dump on DHCPserver for Intel Pro/1000 MT Desktop testrun

Changed 10 years ago by Neighbour

Host traffic dump for Intel Pro/1000 MT Desktop testrun (filtered on VM-MAC and broadcast MAC)

Changed 10 years ago by Neighbour

VBox' nictrace on Guest for Intel Pro/1000 MT Desktop testrun

Changed 10 years ago by Neighbour

Screenshot taken after Intel Pro/1000 MT Desktop testrun

comment:1 Changed 10 years ago by frank

Is this still an issue with VBox 3.0.8? This version has a fix for the PCNet network device emulation which could be related to your problem.

comment:2 Changed 10 years ago by Neighbour

All the 3 tested VM's (debian lenny x86, ubuntu server 9.04 x86, and ubuntu desktop 9.04 x86) now have a working bridged network with the PCNet-fastIII adapter. As far as I can see, the issue is fixed in 3.0.8.

comment:3 Changed 10 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for your feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use