VirtualBox

Ticket #5083 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Windows XP Guest can only access one physical CD/DVD per boot

Reported by: lvskiprof Owned by:
Priority: major Component: DVD
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Solaris

Description

The CDROM/DVD drive sort of works, but it remembers the first disc it sees and like an elephant it never forgets it until you reboot the VM. If you eject the disc and put in a different one you will see the contents of the first disc when you explore the device.

You can change CD/DVD image files from your list all day long and not have this problem. Although you do need to have them set up in advance first. If you forget you can cheat a bit by creating or using another VM to which you add the names of image files. Those files are then available to mount under a currently running VM.

I have been seeing this on the snv_111 SXCE build of Solaris X86.

The only workaround I have found is to either create an image file or reboot the VM.

I have also noted that under Solaris I have problems ejecting the disc. I have to ask to eject it once, upon which I get an error dialog saying that it can't. If you have the Computer window open at the time you will see the icon for the disc change to a drive with a disc in it after you click OK in that dialog box, but it still has the name of the disc title for the icon. Right click on it and ask to eject again and it succeeds and the icon changes to an empty drive.

I am not sure if this is an interaction between VB and Solaris or not. Possibly the issue under Windows in a VM is a VB bug and the other is a Solaris/Gnome bug. In either case it should Just Work seamlessly and it does not.

Change History

comment:1 Changed 5 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to duplicate

comment:2 Changed 5 years ago by ramshankar

Duplicate of #5077

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use