VirtualBox

Ticket #5082 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Windows XP Guest fails to access USB memory card reader on Solaris

Reported by: lvskiprof Owned by:
Priority: major Component: USB
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Solaris

Description

I have been working with several people on the Solaris X86 Yahoo alias to try and resolve this issue. I am using the SXCE release of Solaris X86. I have tried snv_111 and snv_123 for this.

Note that Solaris X86 recognizes cards inserted into this device just fine and pops up a file manager windows when I do so. So this is not a device Solaris has a problem handling. I also know that it works fine on a native Windows system (of course).

I am trying to access a memory card reader. VB Settings does detect the device to add a filter for me automatically. Here are the filter details:

Generic Mass Storage Device [0100] 058F 6366 0100 Generic Mass Storage Device 058F0O1111B1 <blank> No

Unfortunately it fails to attach in the Windows XP Guest, where it gives an error:

Callee RC: NS_ERROR_FAILURE (0x80004005)

Trying to get a version that had the bug fix for 6849326 in it (fixed in snv_122) I upgraded to snv_123. No change to my results.

One person suggested that he changed the last two lines in /etc/logindevperm so that the 0600 for the two USB device types listed there was changed to 0666.

Strange as it may seem, this actually did work better. At least it saw the reader and it attached to it. Windows presented the expected messages about a new device being found and I saw a new drive icon with a letter assigned to it appear.

Unfortunately the second I put a Compact Flash card in the reader the Windows VM hung, and I mean hung hard. Nothing in Windows XP responded to the mouse (although I think the pointer did change to the Windows one). The only thing for the VM window that responded was the close button in the upper left, and I had to wait until it asked me to do a Force Quit (Gnome asks that) to get it to shut down. The VB application was still responsive, so I could have used that instead.

My system is configured like this: Two Dual Core AMD Opteron 2.8GHz CPUs Dual 1TB drives with multiple ABEs on them using mirrored ZFS boot partitions 6 500GB drives configured as a single RAID 5 ZFS volume of about 3TB with one as a hot spare 32GB of RAM Dual Gb Broadcom NICs Adaptec adpu320 SCSI card w/tape drive nVidia video card with dual outputs to two monitors Working sound, USB, and Firewire devices All devices in the system are fully supported by Solaris X86

USB devices should Just Work with a VM and not even require a filter, but I could live with that in this case if the bloody thing would just work as it is supposed to.

Feel free to contact me about this bug. I desperately need this feature to work correctly for the development work I am doing under Windows XP on this system. I have enough ABEs that I can always create a new one for testing a fix.

Attachments

logindevperm Download (1.8 KB) - added by lvskiprof 5 years ago.
Modified /etc/logindevperm file
VBox.logs.zip Download (36.0 KB) - added by lvskiprof 5 years ago.
Zip file of logs from 9/29/2009 showing problems with VM crashing w/USB

Change History

Changed 5 years ago by lvskiprof

Modified /etc/logindevperm file

comment:1 Changed 5 years ago by lvskiprof

Set your weird-o-meters to full guys...

Today I am working in my snv_111 ABE again and I had to re-attach the card reader to the system. I used to have it plugged in the back, but was trying to use it on another system where Windows is running Native.

So when I plugged it in I hooked it up to this USB + Firewire thingy I have in place of my floppy drive, because it is more convenient than trying to plug it in the back again, especially since I was going to move it right after this.

Damned if the device didn't get read under the Windows VM I already had running. I have that change still in the /etc/logindevperm file for this ABE.

The one difference I can really point to is that I attached it after the VM was up and running, plus it is on a different USB controller number (c11 instead of c7).

I noticed that I had to disable that filter in VB before Solaris saw it, so it is available either in the VM or in Solaris, not both at the same time. But that is something I can easily live with.

comment:2 Changed 5 years ago by ramshankar

Under no host does VirtualBox support sharing USB devices between host and guest (like an iPhone where Photos are loaded on the host and the guest is given some other configuration).

comment:3 Changed 5 years ago by ramshankar

  • Priority changed from blocker to minor

comment:4 Changed 5 years ago by lvskiprof

Yes, I figured that out when it finally started to work last night. But what I had to do to get it to work seems to suggest that USB support in VB is broken. I should not have had to edit a file manually in /etc.

comment:5 Changed 5 years ago by ramshankar

Agreed on Solaris hosts there's still work being done in this area and will get much better.

comment:6 Changed 5 years ago by lvskiprof

I still think this should be considered a blocker, or something more serious than minor. Last night it actually worked fine. Today I tried it, bringing up the VM (which I had the state Saved for from last night) and when I plugged a memory card in the VM crashed. Another time it simply hung and had to be aborted. I forget just which problem happened first. I am currently running that VM without the reader attached, but when I attach it (with no card inserted) I get an error saying it is currently busy with a request. Anything that can kill or freeze a VM is more than "minor".

I am going to attach my logs from today in a zip file. The .3 file shows the errors I was getting the first time. I am hoping the others may be of some use as well.

Changed 5 years ago by lvskiprof

Zip file of logs from 9/29/2009 showing problems with VM crashing w/USB

comment:7 Changed 5 years ago by lvskiprof

Final note. When I got that error saying it was busy with a previous request I tried to deselect the USB device for the VM. That hung the VM. You should see that in the VBox.log file in the zip file I just uploaded. It looks similar to what is at the end of the .3 file.

comment:8 Changed 5 years ago by ramshankar

  • Priority changed from minor to major

Blockers are far more serious bugs like freezing the entire host or complete install failures. I can move this to major but the fix will take time as part of newer USB support.

comment:9 Changed 4 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed

Please try VirtualBox 3.1 (NOTE! requires Solaris nevada 124 or higher) since it has rewritten USB support, please re-open the ticket if the problem persists.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use