VirtualBox

Ticket #5025 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

VERR_VM_DRIVER_VERSION_MISMATCH errors under kernel 2.6.31

Reported by: adrianb Owned by:
Priority: major Component: VMM
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

When starting up a VM on a host running kernel 2.6.31, the message "The VirtualBox kernel modules do not fit to this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing '/etc/init.d/vboxdrv setup' should fix that problem." is displayed.

VirtualBox on a dual core Intel laptop running 2.6.31 works without error. It fails on an AthlonXP desktop.

I've tried OSE versions of 3.0.4 and 3.0.6. They work on the laptop but not on the desktop.

VirtualBox and all modules are built manually and VirtualBox is run directly from the build output directory. No logs are created because the VMs don't start.

dmesg on the desktop contains:

vboxdrv: Trying to deactivate the NMI watchdog permanently... vboxdrv: Successfully done. vboxdrv: Found 1 processor cores. vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'. vboxdrv: Successfully loaded version 3.0.6_OSE (interface 0x000e0000).

On the same desktop machine, VirtualBox works under kernel 2.6.24.7.

Attached is my desktop machine's 2.6.31 kernel configuration for anybody interested in trying to reproduce the problem.

Attachments

config Download (41.0 KB) - added by adrianb 5 years ago.
2.6.31 kernel configuration file
build-vbox.log.bz2 Download (31.6 KB) - added by adrianb 5 years ago.
virtualbox build log
build-modules.log Download (20.6 KB) - added by adrianb 5 years ago.
virtualbox modules build log

Change History

Changed 5 years ago by adrianb

2.6.31 kernel configuration file

comment:1 Changed 5 years ago by frank

Actually this is the wrong place to ask. Go to the  forums to ask such questions. The official packages from www.virtualbox.org should install fine. The message which was displayed belongs to the official packages and not necessarily to OSE packages.

How did you create the OSE package? How did you install it?

comment:2 Changed 5 years ago by adrianb

Can the possibility that this is a VirtualBox bug be ruled out, given the facts above?

I compile the OSE release with the following options:

$ ./configure --disable-dbus --disable-python --disable-hardening --disable-pulse --with-qt-dir=/usr/local/Trolltech/Qt-4.4.0/

And then i compile the kernel modules normally. I run VirtualBox from inside the release bin directory.

comment:3 Changed 5 years ago by frank

Well, what means normally, how do you actually compile the kernel modules? I would appreciate if you could add the complete build.log (please use the attach button!) including the part when you compile the kernel modules.

comment:4 Changed 5 years ago by adrianb

Sorry, what i meant by "normally" is that i cd into the bin/src directory and just run make.

I can't find a build.log anywhere. How can i cause that to be created?

comment:5 Changed 5 years ago by frank

rm -rf out/
./configure ....
source env.sh
kmk > build.log 2>&1
cd out .... bin/src
make >> build.log 2>&1

comment:6 Changed 5 years ago by adrianb

Hi. I lost my internet access at home for 2 days. I'm attaching the build logs to this post.

Changed 5 years ago by adrianb

virtualbox build log

Changed 5 years ago by adrianb

virtualbox modules build log

comment:7 Changed 5 years ago by frank

Well, these logs look fine. The question is if the directory /usr/src/linux-2.6.31 indeed contains the very same sources which the current running kernel was compiled from. Even if you changed one config option or if you changed one tool which was used for building the kernel (in particular the gcc compiler) it might happen that the kernel source tree does not match anymore to the currently running kernel. Therefore you should

  1. rebuild the kernel in /usr/src/linux-2.6.31
  2. install it properly including the modules and make sure this kernel
  3. reboot into this new kernel
  4. rebuild the VBox kernel modules
  5. load the VBox kernel modules

comment:8 Changed 5 years ago by adrianb

Yes, i've done all those things countless times while trying to figure out this problem.

For now i've gone back to 2.6.24.7. Under that kernel, i can switch from one version of vbox to another without rebooting.

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use