VirtualBox

Ticket #4994 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

GuestAdditions still does not work well.

Reported by: fgnicodemos Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

GuestAdditions is still not working well in Linux fedora 10, 11. When you try to update the previous version 3.0.6 from 3.0.5 some errors still apper.

Error: removing module vboxadd version 3.0.5 removing modulo vboxvfs version 3.0.5

Error module vboxadd and vboxvfs 3.0.5 did not found.

In the end it updates but it still need some fixes.

The second issue is that when powering off the Fedora 10 virtual machine the screen continues the same and do not show finishing the tasks in a smaller black window. This causes the virtual machine to be aborted instead of a properly power off.

This issue also happens in Windows XP.

I think guestadditions still need some additional fixes.

Thanks

Change History

comment:1 Changed 5 years ago by frank

Regarding the first issue: Which fixes are needed? Do you have DKMS installed in your guest?

Regarding the second issue: Please attach a VBox.log file of such a session. Do you have 3D guest support enabled? Does the abort still happen with disabled 3D support?

comment:2 Changed 5 years ago by fgnicodemos

I think that some operationanl fixes are needed. I also think that some more test would be nice. For example:

1) When i finish my Vbox Machine using Fedora 7 the windows automatically reduce size and all the stopping services appear. This does not happen with Fedora 10 and 11. The window keeps the same size and sometimes the final result is machine aborted not powered-off.

2) When my window is recised (both in Windows and Linuxes) the operation window does not fits automatically the window. I have to move the borders and click in the Maximize to the window fit all the area. 3) Some erros in the instalation appear.

Sorry i could not reproduce it again yet. So i can not attach the .log file. It is not a constant behavior.

It happens with both 3D guest support enable and disabled. And Yes for sure i have the DKMS package support instaled in all Linux machines and before install Guest additions.

So let me know how i can help with more information, as i am relative new (6 months) using Vbox. I also do not develop sources for Vbox.

comment:3 Changed 5 years ago by frank

You can be assured that we do a lot of testing before we release a new version. The problem is to cover all possible combinations of hosts, guests and environments.

If the machine state is aborted then your VM crashed during shutdown and this is most probably not related to the guest additions.

The preferred way to help is to exactly describe the problem in a way that we can reproduce it.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use