VirtualBox

Ticket #4984 (new defect)

Opened 5 years ago

Last modified 6 months ago

Losing Guest Connectivy On Bridge Mode

Reported by: firefly Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.6 Keywords: network , bridge , losing connectivity , drop , connection
Cc: Guest type: other
Host type: other

Description

Background: I am running VirtualBox 3.0.6 on OpenSuse 11.1 64bit Window 2003 Std Server on Bridge mode networking. I have two network card. The Win03 machine is bridge to eth1.

Problem: The Win03 guest machine kept on losing network connection. It doesn't show any error but the network just stop responding (i.e. can't surf the network). When this happen all other guests that also bridged to the same network interface will lose connection as well. So I suspect the problem is with the bridged driver at the host level.

Restarting the guest will fix the problem. Sometimes the connection will come back up by itself after awhile. I have started to experience this problem since 3.0.4 and the same problem still persist in 3.0.6.

Attachments

VBox.log Download (42.7 KB) - added by firefly 5 years ago.
VBox.2.log Download (76.4 KB) - added by sc1993 5 years ago.

Change History

Changed 5 years ago by firefly

comment:1 Changed 5 years ago by firefly

It's also worth mentioning that this doesn't just happen with the Win2003 guest machine. This happen to other guest machine that bind to eth1 interface as well including another OpenSuse 11.1 64bit Guest.

comment:2 Changed 5 years ago by DOCa Cola

it seems to be similar to the issue reported in this thread:  http://forums.virtualbox.org/viewtopic.php?f=8&t=22305 I am using Mac OS X Server 10.6 with 3.0.6 and experience the same issue with Windows Server 2003. Another OS X Sever user is reporting the same with an Ubuntu Server guest.

so again what i have written in the forum thread - just for the record: i experience the same issue with 10.6 server with 3.0.6 with windows server 2003 guest. the bridged network connection runs absolutely fine at first, but after a few hours the guests lan connection is not working anymore. i have to shutdown the virtual machine entirely (restarting the guest system or disabling/reenabling the network connection from the menu has no effect). the guest has been copied over from another system that previously ran virtualbox 3.0.4 under 10.5 and first installed with 3.0.0. the guest additions have been upgraded to 3.0.6 also. 10.6 server runs on a mac mini with only the integrated wired lan connection (airport disabled). also a pppoe internet connection is made (dynamic ip) with that server to the internet

comment:3 Changed 5 years ago by sc1993

I am running an FC11 host with VirtualBox 3.0.6 hosting two FC10 guests (samba servers), configured in bridged network mode (Intel PRO/1000 MT Server). During heavy network load of a guest, it freezes. This almost always happens at night, when automatic backup runs (rsync). The only way to solve the problem is to power off the guest and restart it.

Changed 5 years ago by sc1993

comment:4 Changed 5 years ago by virtual_w12

I am seeing the same issues as OP on a Mac OS X 10.5.8 host and an OpenSolaris 2009.06 guest. Guest uses the AirPort connection on a Mac Mini in bridged mode with the Intel Pro 1000 MT Desktop network card. Both VirtualBox 3.0.6 and 3.0.8 have problems, I'm trying 3.0.2 right now. There appears to be another state between "networking completely functional" and "networking completely dead": I can ping the guest, but the ping responses come in late and all at once, i.e. ping sends out 30 packets, one each second, and after half a minute or so, it receives all responses with round trip times between 0 (the most recently sent packet) and 30000ms (for the first packet sent).

comment:5 Changed 5 years ago by virtual_w12

Addendum: VirtualBox 3.0.2 shows the same behavior.

comment:6 Changed 4 years ago by sovnarkom

Hi there!

I am using VirtualBox 3.0.8r53138 on OS X 10.6 host with Ubuntu Karmic Server with bridged interface en0

Connectivity between host and virtual machine is always ok, but after virtual machine shutdown host is also loses connection to router until reboot or virtual machine boot.

Another one problem: from time to time other real hosts in network lose connection to virtual machine via router. But this problem can be solved by updating dhcp binding on VM, in my case: "sudo dhclient".

comment:7 Changed 3 years ago by ezorro

This looks to me like a ARP cache problem. Are you running copies of the same VM in the same Network? Check VMs for equal MAC adresses. At least in a subnet/boradcast domain MAC addresses MUST be unique.

comment:8 Changed 6 months ago by andrass9

Hi there!

I know it is an old ticket but I encountered similar problem:

Virtual Box is 4.2.8

Host: Vector Linux Gold 7 (Slackware 13.47), Linux kernel 3.11.1.

Guest: Windows 2003 standard.

All of them are 32 bits.

Guest has one ethernet interface which is bridged to eth1 on the host. Eth1 has a fix IP range routed through ppp0. I assigned 3 IP addresses to the guest, 2 out of the fix IP pool and 1 local IP. Guest runs email server on the two fix IPs.

The problem is, that the bridge losing connection to the internet over time. The guest still can access everything out there, but there are no more incoming connections. Can't even ping the guest from the internet. Sometimes it takes an hour to fail, sometimes works for half a day without hiccup.

The strange thing is, that locally from the same subnet I can access the guest.

When I tried to restart the guest from the saved state, it doesn't work. I have to shut down the guest, stop the VM and reboot to make it working again.

Last edited 6 months ago by andrass9 (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use