VirtualBox

Ticket #4956 (reopened defect)

Opened 5 years ago

Last modified 4 years ago

Installer fails with error 1603

Reported by: nagi Owned by:
Priority: critical Component: installer
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Trying to install version 3.0.6 on Windows Vista. After all the confirmation the installer starts. But after seconds the scrollbare runs back and an error is showed:

Virtual Box Installer Installation of MSI failed Error: 1603

Change History

comment:1 Changed 5 years ago by ranger203

Wow, I just had the same problem installing 3.0.6. Installing on the following:

Windows 7 64-Bit E6300 Core 2 Duo 8GB RAM UAC Disabled

Fix that worked for me:

  1. Enable UAC & Reboot
  2. Right click, Install Vbox as Administrator

You should be able to install Virtual box now, and disable UAC afterwards. Please list your system specs and whether the fix worked or not.

comment:2 Changed 5 years ago by pentagonik

@nagi: Please take a look at the following  this page to enable installation logging. Please attach both files (installer + driver installation log) to this defect then. Thanks!

comment:3 Changed 5 years ago by nagi

Hi

I used the MS CleanUp tool and could so remove some old VBox 2.20 stuff. After that the installation worked fine.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Ok, so nothing we can do so far. There were some installer fixes after 2.2.0 so the problem is probably already resolved.

comment:5 Changed 4 years ago by efstanley

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I am trying to install VirtualBox on an XP, SP 3 machine. I downloaded VirtualBox-3.1.2-56127-Win.exe When I run it I get Error 1603 Installation of MSI failed. I have plenty of disk space so I am unable to determine why it fails.

comment:6 Changed 4 years ago by sandervl73

  • Priority changed from blocker to critical

Without an installation log (see  http://www.virtualbox.org/wiki/MSI_Logging) there is nothing we can do.

comment:7 Changed 4 years ago by oolokioo

Same problem... Error code 2755 and 1603, when i installing VirtualBox.

Windows 7 64b

VirtualBox v.3.2.2

Screenshot:  http://www.sendspace.com/file/uf5o8v

Installation log:  http://www.sendspace.com/file/29oblj

comment:8 Changed 4 years ago by pentagonik

@oolokioo: What happens if you first extract the files from the VirtualBox .exe package using the "/extract" switch, move the files of the directory just named in the message box to, let's say, the desktop and start installer by doubleclicking on one of the .MSI files (depending on your OS)?

comment:9 Changed 4 years ago by oolokioo

After "-extract" I got 3 files:

common.cab

VirtualBox-3.2.2-r62321-MultiArch_amd64.msi

VirtualBox-3.2.2-r62321-MultiArch_x86.msi

It's the same effect, when I running .msi files. But in common.cab I can see - VBoxGuestAdditions. Is that what I need?

comment:10 Changed 4 years ago by pentagonik

@oolokioo: No, the Guest Additions, as the name implies, are only meant for the guest OS. And you did move the files out of the temporary directory where they were extracted to another directory (just to be sure)?

comment:11 Changed 4 years ago by oolokioo

@pentagonik Of course. I extracted with setting path: %filename% -x -p D:\TEMP

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use