VirtualBox

Ticket #4951 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VBoxGuestAdditions.iso not found after an upgrade. (Vbox refuses to continue with a saved image)

Reported by: zephyrus Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: other
Host type: other

Description

Host: Win/XP 32bit Guest: Debian/GNU Linux 32 bit VirtualBox: 3.0.6

I noticed the availability of 3.0.6 and saved a running image of linux 32 bit version, and also saved a running version of solaris10 (64 bit).

Please not that I have not shutdown the OS images, but rather simply quit the Vbox and let it save the current states.

After the upgrade, when I tried to run linux 32 bit version, Vbox reported that one of the CD/DVD images are no longer accessible and refused to restart the image.

When I checked, VBox was looking for VBoxGuestAddtions.iso. (Which I think is a natural. I mean all running instances will mount it implicitly.)

Now, I checked the windows C drive where VBox installed to see if I messed up the upgrade. Well, the iso image was right there.

C:\Program Files\Sun\VirtualBox\VBoxGuestAdditions.iso

Then why VBox refused to continue with my saved image?

I scratched my head a few times, then I noticed the following.

VBox recorded the full pathname of the ISO file using partially DOS-style 8.3 name, thusly. c:\Program Files\Sun\XVMVIR~1\... The last part is omitted.

That is "VirtualBox" was recorded as old-fashined DOS 8.3 name, which I am afraid has changed to a different one during the upgrade.

So hoping to continue with the saved image, which contained rather up-to-date edit of a few files, I created "XVMVR~1" directory and copied the iso file there.

Voila, VBox now let me run / continue with my previously saved linux image.

My two cents worth for anyone troubled with a similar bug/problem/feature on Windows/XP host.

PS: Solaris 64 image could not be restarted any more, due to a strange kernel trap in 3.0.6 for now. What a pain. (see ticket # 4947 reported by someone else first.)

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Actually this is a duplicate of #920 and I agree that this is very annoying. Regarding the guest additions image: After you installed the guest additions -- the menu point does not more than just mount the .iso image -- you can unmount that image.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use