VirtualBox

Ticket #4925 (closed defect: duplicate)

Opened 5 years ago

Last modified 8 months ago

Unidirectional close does not work on NAT port forwards

Reported by: mast Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

I have a setup with a tcp server in a windows vista guest. This server listens to a port which the NAT forwards connections to from the outside. I (normally) connect to the tcp server from a client on the linux host via the lo interface.

The client opens a connection, writes a request and then closes the write side of the connection (shutdown(2) with SHUT_WR). After this, the client waits for a response on the read end. The server sends several packets of response data, but the client only receives the first packet.

Observations:

If I don't close the write side on the client, it gets all packets.

If I connect to the server from inside the vista guest, it works with the write side close in the client (using winsock shutdown).

I believe this worked in VirtualBox 2.1, but I'm not certain.

I've verified that the server does not depend on the close of its read end to start sending a response.

Attachments

VBox.log Download (37.3 KB) - added by mast 5 years ago.

Change History

comment:1 Changed 5 years ago by Hachiman

Could you please attach the log file? Does it change with  3.0.6 b1?

Changed 5 years ago by mast

comment:2 Changed 5 years ago by mast

Log added. A request which got prematurely closed was made at the end.

The problem is the same in 3.0.6 b1.

comment:3 Changed 5 years ago by Hachiman

Is it acceptable for you to share your application with me to have good testcase? If yes or with some conditions please contact me at [vasily _dot_ levchenko _at_ Sun _dot_ COM]

comment:4 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

comment:5 Changed 9 months ago by jonseymour

  • Status changed from closed to reopened
  • Resolution obsolete deleted

I have managed to reproduce this problem with Virtual Box 4.3.10 running on an OSX host. Details in https://www.virtualbox.org/ticket/13116

comment:6 Changed 8 months ago by vushakov

As noted in https://www.virtualbox.org/ticket/13116 this should be fixed in the next dot-dot release.

comment:7 Changed 8 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

No need to reopen this ticket if everything is described in #13116. The more duplicate tickets open the more work for the developers to take care of them and the less time for actually fixing bugs.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use