VirtualBox

Ticket #4910 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

VirtualBox causes GPE storm on macbook pro 5,2

Reported by: jealma Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

I used Ubuntu 9.04 on my MacbookPro 5,2 without many problems (stock kernel 2.6.28.x). Since I switched to ArchLinux, using kernel 2.3.30.5, I get GPE storm errors as soon as I start a VirtualBox VM. The exact error is "ACPI: EC: GPE storm detected, transactions will use polling mode". Other errors then show up in dmesg, like: "CE: hpet increasing min_delta_ns to 15000 nsec"

My host machine pretty much keeps working as expected, except for the clock which starts counting irregularly and skipping a few seconds every time. My virtual machines become agonizing slow at startup and the GUI's from both my ubuntu guests as the windows xp guests freeze for approximately 5 seconds after every 30 seconds, making them practically unusable.

I've tried playing with hpet=disable; acpi_osi=Darwin; leaving reboot=pci out of kernel parameters (I need that parameter for rebooting to work) and others, but to no avail. I also tried the async parameter for the vboxdrv, but that didn't do any good either.

A pfSense guest VM also starts spawning these messages: "calcru: runtime went backwards from 1019 usec to 983 usec for pid 37 (bufdaemon)". Those messages normally don't appear in the console. Sometimes, the pfsense's kernel panics during boot, so I have to restart the VM.

Attachments

dmesg-090902.txt Download (37.2 KB) - added by jealma 5 years ago.
dmesg output from my MBP5,2 after GPE storm has occurred

Change History

Changed 5 years ago by jealma

dmesg output from my MBP5,2 after GPE storm has occurred

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate. Search for archlinux.

comment:2 Changed 5 years ago by jealma

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Yes there are other issues where Archlinux is used as hostOS, but none related to GPE storm errors. In fact, this is the only issue where anything of a GPE storm is mentioned, therefore I think this bug is not a duplicate of any other bug.

comment:3 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate

No, you need to look better. It's fixed in 3.0.6 beta 1.

comment:4 Changed 5 years ago by sandervl73

comment:5 Changed 4 years ago by erinyes

Even though you say this bug is closed in the 3.0.6 Beta 1 release, I'm still experiencing theese problems. Im using a macbook 2,1 (3,1 hardware). And the GPE Storm problems are exactly as others has described. I recently upgraded to version 3.1.0 still no sign of this isue resolving. Im using Ubuntu Karmic 9.10.

My girlfriend also has a macbook (5,1), so i tested it on that. The same ocours.

Any thoughts?

comment:6 Changed 4 years ago by jealma

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I also experience this problems still. VirtualBox is unusable on MBP + linux with kernel 2.6.29 and higher. See also this kernel bug:  http://bugzilla.kernel.org/show_bug.cgi?id=13502

comment:7 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use