VirtualBox

Ticket #4883 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Windows Guest input misbehavior

Reported by: jhmdev Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.4 Keywords: scroll wheel,
Cc: Guest type: Windows
Host type: Mac OS X

Description

Windows XP guest will become unusable after varying amounts of time. Keyboard events will be ignored or mis-interpreted. The scroll wheel causes the fonts in an application to shrink (like I'm zooming out), even in applications that do not support zooming, such as ActiveState Komodo Edit 5.0. After this problem occurs, I can no longer bring up windows by clicking on the status bar. I can only right click on the window button and click close. VirtualBox itself never crashes.

Host: Mac OSX 10.5.8 Guest: Windows XP Service 3 Hardware: MacBook Pro

Attachments

VBox.log.1 Download (51.8 KB) - added by jhmdev 5 years ago.
the VBox log from the most recent incident

Change History

Changed 5 years ago by jhmdev

the VBox log from the most recent incident

comment:1 Changed 5 years ago by letezo

The same happens to me in all of my VMs.

Host OS: Ubuntu 9.04 amd64 Guest OSes affected: Windows XP, Windows Server 2003 and Ubuntu 8.10, basically guest OS type independent

Guest additions are installed properly in all the VMs.

It does not depend on time, it seems to be caused by "locked in" modifier keys. Pressing all the modifier keys, like all the shift, ctrl and alt keys is the common workaround in this situation, but it is very disturbing and interrupting the usual workflow very often. Slowing down typing and clearly separating the keypresses usually helps, but also disturbing.

Sometimes the Host OS gets the Alt-TAB, even when in full-screen mode.

If the guest OS displays a notification bubble like a new SkyPE message it just brings over the VM in full screen mode and pressing a key at the same time often steals the focus and causes unexpected behavior.

There are many related cases and all of them seem to be caused by the failure of VM user interface separation in fulls screen or grabbed modes.

I guess it does happen to most of the users, just not all of them reports this bug.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.1.6. In that case, attach a VBox.log file of such a VM session.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use