VirtualBox

Ticket #4876 (new defect)

Opened 5 years ago

Last modified 3 years ago

A duplicate name exists on the network - Windows Error

Reported by: xok Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

VirtualBox Guest has problems with DHCP leases managed by ASUS Wireless Router RT-N11 (host connected by cable).

Guest does the DHCP has grabs an IP address although it is not accessible by the network name, only by IP address.

See images attached.

Attachments

dhcp_guest.png Download (18.6 KB) - added by xok 5 years ago.
Guest - DHCP Lease
devxp-2009-08-29-19-49-09.log Download (52.1 KB) - added by xok 5 years ago.
devxp-2009-08-29-19-50-26.log Download (1015 bytes) - added by xok 5 years ago.
devxp-2009-08-29-20-13-30.log Download (59.6 KB) - added by xok 5 years ago.
devxp-2009-08-29-20-29-00.log Download (43.9 KB) - added by xok 5 years ago.
ping.png Download (6.2 KB) - added by xok 5 years ago.
Ping from host

Change History

Changed 5 years ago by xok

Guest - DHCP Lease

Changed 5 years ago by xok

Changed 5 years ago by xok

Changed 5 years ago by xok

Changed 5 years ago by xok

Changed 5 years ago by xok

Ping from host

comment:1 Changed 5 years ago by xok

Aditional information:

Guest connect as BRIDGE connection to the a RealTek NIC.

HOST - Windows XP SP3 GUEST - Windows XP SP3

comment:2 Changed 5 years ago by michaln

The error message you got from Windows means exactly what it says. Some other machine on the network is already using the name, and the newly started machine (VM) refused to use the same name. You need to change your VM's network name from vdev to something else.

This is a Windows networking problem, it has nothing to do with VirtualBox. It's very easy to get into this situation when cloning machines (physical or virtual).

comment:3 Changed 5 years ago by xok

I undestand what you are saying but you are wrong, this behaviour started to happen on the VirtualBox version 2.2.2.

The network scheme is very simple, there is only a router connected with 2 PCs only.

ROUTER 192.168.1.1 PC1 - 192.168.1.11 (IP Lease associated by MAC address) - \MH PC2 - 192.168.1.12 (IP Lease associated by MAC address) - \MACHINE VM GUEST (Bridged on MH) - 192.168.1.30 (IP Lease by DHCP) - \VDEV

There isnt any other name conflit and is the only VM started. Even changing the name of VM, the error does not go away (already tested it... before posting).

comment:4 Changed 5 years ago by xok

(Sorry for re-posting but the box only generates a <BR /> for 2 "ENTER" chars)

* Information above:

ROUTER 192.168.1.1

PC1 - 192.168.1.11 (IP Lease associated by MAC address) - \MH

PC2 - 192.168.1.12 (IP Lease associated by MAC address) - \MACHINE

VM GUEST (Bridged on MH) - 192.168.1.30 (IP Lease by DHCP) - \VDEV

comment:5 Changed 4 years ago by gregdavisfromnj

After upgrading virtualbox and the corresponding guest additions to 3.0.12, my 32bit Windows XP SP3 guests start up and give me an error dialog at the login prompt stating "a duplicate name exists on the network." I have identified the culprit as having 2 NICs in each VM: 1 on NAT (10.0.2.x) and 1 on host-only network (192.168.56.x). I went through and regenerated MAC addresses via the vbox settings dialog for all of these cards to see if there was a duplicate there; no duplicate and didn't fix anything. Starting the VMs with only 1 NIC active solves the problem, but I kind of need both active most of the time. First, it ensures that the TCP stack in the guest starts up and its network software doesn't complain. Second, it allows me to have the guests connect to each other, but prevents the WAN/Internet from connecting to the guests. Using vbox versions 3.0.10 and prior, I didn't have this problem.

I suspect both xok and I have a network cycle such that the same machine is receiving its own broadcasts, and telling itself that its name is already taken. FWIW, I don't have any problems with my Kubuntu guests (with 2 NICs on the same networks), so the problem seems to be with windows networking. In xok's case, the cycle is probably introduced by his physical network. In my case, I suspect a bug has crept into the windows guest additions in version 3.0.12 and thereafter that is bridging or connecting the NAT and host-only networks. I only get the duplicate name error after upgrading the additions.

For kicks and giggles, I will remove the additions altogether first, before trying to reinstall them (rather than installing over the previous version as I have done).

comment:6 Changed 4 years ago by gregdavisfromnj

Removed the additions, rebooted a couple of times, no duplicate name complaint. Installed additions as if for the first time, rebooted, duplicate name complained about. Seems like the cause is the guest additions, and not how they were installed. The NICs work without the additions, so looks like the problem is not the virtualbox host software.

comment:7 Changed 3 years ago by gstanden

 http://social.technet.microsoft.com/Forums/en-US/winserverManagement/thread/01795be9-19c0-4caa-846f-1002d8c7ca99

Reference the above URL. What it says at that link, which worked, is basically, you have to disable NetBIOS on the additional adapters (such as NAT, bridged, etc. - and - it will still work just fine if you do). My need was to have the multiple adapters do what they need to but also stop getting the "duplicate name exists on the network" error. You can go to the link above to get the solution, but I've also pasted it in here too from that link:

This issue will occur if NetBIOS over TCP/IP is enabled on multiple NICs. When multiple interfaces have NetBIOS over TCP/IP enabled on the same network for a server, the system will attempt to register multiple IP addresses for the same NetBIOS name from the same computer. This will cause NetBT errors. Please try to disable NetBIOS on the new-added network adapter to test this issue. To do so:

  1. Open TCP/IP properties of the new network connection.
  1. Click Advanced button on General tab.
  1. On WINS tab, select "Disable NetBIOS over TCP/IP" and click OK to quit.

Note: Disable NetBIOS over TCP/IP will not affect the name resolution in your network environment as DNS is the recommended option for name resolution on Windows Server 2003. [ Note: I am just using a workgroup and a hosts file, not DNS, and everything still worked fine after disable NetBIOS on my NAT and Bridged adapters fyi ].

This link tells all about NetBIOS:

 http://technet.microsoft.com/en-us/library/bb727013.aspx

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use