VirtualBox

Ticket #4875 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

AMD Turion MT-40 not properly detected?

Reported by: Marcus Schätzle Owned by:
Priority: minor Component: host support
Version: VirtualBox 3.0.4 Keywords: AMD Turion MT-40 host support
Cc: Guest type: Linux
Host type: Windows

Description

Until some days ago I had a Turion MT-40 CPU (mobile single core 64Bit) in my PC. Now that I switched to an Intel Pentium Dual-Core E6300, I realise that the option of installing a 64-Bit guest was not offered for the Turion, even though it is a 64Bit CPU, and I used to have a VBox Version that was supposed to offer this option. Strange enough, I was offered the option to activate AMD-V, which is to my knowledge not available for the Turion MT and ML lines for socket 754, but only for the Turion MK für socket S1.

Host was (and is still after the CPU change) Windows XP. I don't list my guests here for the reason that they have nothing to do with this case.

Attachments

VBox_2.2.4.log Download (72.7 KB) - added by Marcus Schätzle 5 years ago.
AMD-V.jpg Download (138.6 KB) - added by Marcus Schätzle 5 years ago.
AMD-V greyed out but checked on AMD Turion 64 Windows XP 32-Bit system
Linux-Version.jpg Download (149.7 KB) - added by Marcus Schätzle 5 years ago.
Option of installing 64-Bit Linux guests not offered on AMD Turion 64 Windows XP 32-Bit host
VBox.log Download (37.5 KB) - added by Marcus Schätzle 5 years ago.
Log file, this time with version 3.0.4

Change History

comment:1 Changed 5 years ago by frank

There is not much we can do without a VBox.log file. According to  wikipedia, the MT-40 does not have support for AMD-V so I would be surprised if VBox really offered the option to enable AMD-V support for a VM.

comment:2 Changed 5 years ago by Marcus Schätzle

I am going to set up a test PC the upcoming week with my old board so I can attach a VBox.log file here. But I can assure that on my old installation the AMD-V option could be activated, I even had it activated, there was no error msg or something like that.

comment:3 Changed 5 years ago by Marcus Schätzle

I found a backup which contains a log file from my previous VBox 2.2.4 installation with a working Gentoo guest. I attach it for a first lookup. 2.2.4 did not differ in this issue from 3.0.4.

Changed 5 years ago by Marcus Schätzle

comment:4 Changed 5 years ago by frank

The log shows that AMD-V is not used (HWACCM: No VT-x or AMD-V CPU extension found. Reason VERR_SVM_NO_SVM) and is even not available for this CPU (SVM - AMD VM Extensions = 0 (0)). There should be a check in the GUI if VT-x/AMD-V is available on the host (CPUID check) and the option to enable this feature is grayed in the GUI when this feature is not available. There will be no error message if you activate this feature with VBoxManage. OTOH I don't know when we exactly added the GUI check, maybe in 3.0.0 or later (3.0.4 should have it).

comment:5 follow-up: ↓ 6 Changed 5 years ago by Marcus Schätzle

OK, I did a test with my old mainboard now. I can see now that it was indeed not possible to activate AMD-V since this option was greyed out, however it is activated in the checkbox by default, I think it would be better to leave it unchecked (see attached screenshot). The other issue still remains, there is no option offered to install 64-Bit guests, even though the CPU is an AMD64 one. Now that I haved switched to an Intel Dual Core I have this option inside my Windows XP 32-Bit, but with the AMD I had not (see second screenshot).

Changed 5 years ago by Marcus Schätzle

AMD-V greyed out but checked on AMD Turion 64 Windows XP 32-Bit system

Changed 5 years ago by Marcus Schätzle

Option of installing 64-Bit Linux guests not offered on AMD Turion 64 Windows XP 32-Bit host

Changed 5 years ago by Marcus Schätzle

Log file, this time with version 3.0.4

comment:6 in reply to: ↑ 5 Changed 5 years ago by frank

Replying to Marcus Schätzle:

The other issue still remains, there is no option offered to install 64-Bit guests, even though the CPU is an AMD64 one. Now that I haved switched to an Intel Dual Core I have this option inside my Windows XP 32-Bit, but with the AMD I had not (see second screenshot).

This is not a problem because 64-bit guests require VT-x or AMD-V on VirtualBox. Therefore no 64-bit guests without this host processor feature.

comment:7 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

We have an internal defect for taking care of the GUI detection. It's probably a duplicate of some other ticket too, so I'm closing this one.

comment:8 Changed 5 years ago by sandervl73

GUI detection = greyed out, but enabled AMD-V.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use