VirtualBox

Ticket #4860 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Network adapter crashes Vista 64?

Reported by: rayeve Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.4 Keywords: network interface crashes Vista 64
Cc: Guest type: Windows
Host type: Windows

Description

I installed VirtualBox on a new Vista 64 machine. It runs great, except every so often (usually while in an intensive and long download -- but at other times, seemingly random) it crashes my PC to the BSOD. And sometimes mentions an IRQ problem (which goes by too fast to read). But most of the time, it just crashes. Vista then reboots and wants to know if I want to know the cause of the crash. When I elect "yes," it tells me that the network card in my machine has caused the crash and to update to the latest drivers. However: I have(!) the latest drivers according to Vista. Further, the network card shown in the virtual machine (XP) is not the same as the one shown in the host system.

Incidentally, I had exactly the same problem (and error message) when I first tried Windows VirtualPC 2007 to create and XP machine -- before uninstalling and moving to VirtualBox. Anyone know what's going on here? And, if so, what a fix for the problem might be?

I'd send the logfile, etc., but I forgot to save them before (at least temporarily) uninstalling VirtualBox because it appeared to being crashing Vista even when not actively opened! (And, sure enough, the crashes stopped after I uninstalled it).

Many thanks.

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by sandervl73

The network card in the VM is a virtual network card.

The fact that the same happens with VPC suggests your network driver has a problem. Without a minidump ( http://support.microsoft.com/kb/315263) there's not much we can say.

Which network card do you have in your machine? (and which drivers?)

comment:2 in reply to: ↑ 1 Changed 5 years ago by rayeve

Odd thing is, I never have a problem with the network card other than when running the virtual machine. Acts as if it's most likely some sort of problem with the interface between the virtual card and the real one? (Although I'm no software engineer).

Vista shows the card as: Realtek RTL8101

and says the driver is up to date and gives the driver info as:

Rtlh64.sys with version = 6,1837,0926,2006 built by WinDDK

I may reinstall and see if I can get that minidump.

Thanks.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use