VirtualBox

Ticket #4857 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Assertion fail in VBoxManage registervm command => fixed in 3.0.12

Reported by: ronys Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.4 Keywords: VBoxManage registervm
Cc: Guest type: Windows
Host type: other

Description

Hi,

Trying to register a VM created on another machine, I get the following: ERROR: Assertion failed at '/home/vbox/vbox-3.0.4/src/VBox/Main/MachineImpl.cpp' (5034) in nsresult Machine::loadSettings(bool). Unexpected exception 'N3xml11EInvalidArgE' (In 'xml::File::File(RTFILE, const char*)', '/home/vbox/vbox-3.0.4/src/VBox/Main/xml/xml.cpp' at #207). Please contact the product vendor! Details: code NS_ERROR_FAILURE (0x80004005), component VirtualBox, interface IVirtualBox, callee nsISupports Context: "OpenMachine(Bstr(a->argv[0]), machine.asOutParam())" at line 219 of file VBoxManage.cpp

See attached file for the full transcript, including the XML of the file being registered.

This is on a host running Debian Linux: uname -a Linux ackbar 2.6.26-2-amd64 #1 SMP Sun Jul 26 20:35:48 UTC 2009 x86_64 GNU/Linux

Attachments

regsitervm-fail.txt Download (6.7 KB) - added by ronys 5 years ago.
transcript illustrating problem

Change History

Changed 5 years ago by ronys

transcript illustrating problem

comment:1 Changed 5 years ago by dhruwa

I get this exact same issue on a Windows Vista host. I'm running Vista 64 bit.

comment:2 Changed 4 years ago by nowede

The same happens on an ubuntu 9.10 running on 64-bit hw.

comment:3 follow-up: ↓ 4 Changed 4 years ago by klaus

The error message certainly leaves a lot to be desired, but the most vital information for tracking down the bug is missing: the xml file. Since I have no information about the contents I have to assume that you're violating the documented restrictions of "VBoxManage registervm". See VirtualBox manual. Also you cannot register config files created on a different platform (Windows/Linux/Solaris/OSX).

So the only real bug I can see so far is the weird error message, which is mainly a cosmetic issue.

comment:4 in reply to: ↑ 3 Changed 4 years ago by nowede

Replying to klaus:

The error message certainly leaves a lot to be desired, but the most vital information for tracking down the bug is missing: the xml file. Since I have no information about the contents I have to assume that you're violating the documented restrictions of "VBoxManage registervm". See VirtualBox manual. Also you cannot register config files created on a different platform (Windows/Linux/Solaris/OSX).

So the only real bug I can see so far is the weird error message, which is mainly a cosmetic issue.

Here is the complete message and the xml file:

<?xml version="1.0" encoding="UTF-8"?> <!-- Sun VirtualBox Machine Configuration --> <VirtualBox xmlns=" http://www.innotek.de/VirtualBox-settings" version="1.7-linux">

<Machine uuid="{908f06e2-2656-45cb-826f-2cebc8b47801}" name="suse111-64" OSType="OpenSUSE_64" lastStateChange="2009-11-18T07:45:13Z">

<ExtraData>

<ExtraDataItem name="GUI/LastCloseAction" value="powerOff"/> <ExtraDataItem name="GUI/LastWindowPostion" value="3,48,1272,724"/> <ExtraDataItem name="GUI/Fullscreen" value="off"/> <ExtraDataItem name="GUI/Seamless" value="off"/> <ExtraDataItem name="GUI/AutoresizeGuest" value="on"/> <ExtraDataItem name="GUI/MiniToolBarAutoHide" value="on"/> <ExtraDataItem name="GUI/SaveMountedAtRuntime" value="yes"/> <ExtraDataItem name="GUI/ShowMiniToolBar" value="yes"/> <ExtraDataItem name="GUI/MiniToolBarAlignment" value="bottom"/>

</ExtraData> <Hardware>

<CPU count="1">

<HardwareVirtEx enabled="true"/>

</CPU> <Memory RAMSize="350"/> <Boot>

<Order position="1" device="Floppy"/> <Order position="2" device="DVD"/> <Order position="3" device="HardDisk"/>

</Boot> <Display VRAMSize="12" monitorCount="1" accelerate3D="false"/> <RemoteDisplay enabled="false" port="3389" authType="Null" authTimeout="5000"/> <BIOS>

<ACPI enabled="true"/> <IOAPIC enabled="true"/> <Logo fadeIn="true" fadeOut="true" displayTime="0"/> <BootMenu mode="MessageAndMenu"/> <TimeOffset value="0"/> <PXEDebug enabled="false"/>

</BIOS> <DVDDrive passthrough="false">

<Image uuid="{80224d3e-7794-4c26-937e-ca767b216288}"/>

</DVDDrive> <FloppyDrive enabled="true"/> <USBController enabled="true" enabledEhci="false"/> <Network>

<Adapter slot="0" enabled="true" MACAddress="08002796920D" cable="true" speed="0" type="82540EM">

<BridgedInterface name="eth0"/>

</Adapter> <Adapter slot="1" enabled="false" MACAddress="08002734B9FA" cable="true" speed="0" type="82540EM"/> <Adapter slot="2" enabled="false" MACAddress="0800272E245C" cable="true" speed="0" type="82540EM"/> <Adapter slot="3" enabled="false" MACAddress="08002743C1E9" cable="true" speed="0" type="82540EM"/> <Adapter slot="4" enabled="false" MACAddress="0800279F6B5C" cable="true" speed="0" type="82540EM"/> <Adapter slot="5" enabled="false" MACAddress="080027B9A643" cable="true" speed="0" type="82540EM"/> <Adapter slot="6" enabled="false" MACAddress="080027BCAFF9" cable="true" speed="0" type="82540EM"/> <Adapter slot="7" enabled="false" MACAddress="0800279A4538" cable="true" speed="0" type="82540EM"/>

</Network> <UART>

<Port slot="0" enabled="false" IOBase="0x3f8" IRQ="4" hostMode="Disconnected"/> <Port slot="1" enabled="false" IOBase="0x3f8" IRQ="4" hostMode="Disconnected"/>

</UART> <LPT>

<Port slot="0" enabled="false" IOBase="0x378" IRQ="4"/> <Port slot="1" enabled="false" IOBase="0x378" IRQ="4"/>

</LPT> <AudioAdapter controller="AC97" driver="Pulse" enabled="true"/> <SharedFolders/> <Clipboard mode="Bidirectional"/> <Guest memoryBalloonSize="0" statisticsUpdateInterval="0"/> <GuestProperties>

<GuestProperty name="/VirtualBox/GuestAdd/Vbgl/Video/SavedMode" value="1272x676x32" timestamp="1255683156690949000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/OS/Product" value="Linux" timestamp="1255525790149648000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/OS/Release" value="2.6.27.29-0.1-default" timestamp="1255525790151934000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/OS/Version" value="#1 SMP 2009-08-15 17:53:59 +0200" timestamp="1255525790152966000" flags=""/> <GuestProperty name="/VirtualBox/GuestAdd/Version" value="3.0.8" timestamp="1255525790153235000" flags=""/> <GuestProperty name="/VirtualBox/GuestAdd/Revision" value="53138" timestamp="1255525790153403000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/OS/LoggedInUsers" value="1" timestamp="1258530309684936000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/OS/NoLoggedInUsers" value="false" timestamp="1255525865151042000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/Net/Count" value="1" timestamp="1258530309685580000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/Net/0/V4/IP" value="192.168.222.34" timestamp="1256759311851710000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/Net/0/V4/Broadcast" value="192.168.222.127" timestamp="1256759311851905000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/Net/0/V4/Netmask" value="255.255.255.128" timestamp="1256759311852035000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/Net/0/Status" value="Up" timestamp="1256759311852207000" flags=""/> <GuestProperty name="/VirtualBox/HostInfo/GUI/LanguageID" value="de_DE" timestamp="1255525730838526000" flags=""/> <GuestProperty name="/VirtualBox/GuestInfo/OS/LoggedInUsersList" value="norbert" timestamp="1258530309683008000" flags=""/>

</GuestProperties>

</Hardware> <StorageControllers>

<StorageController name="IDE" type="PIIX4" PortCount="2">

<AttachedDevice type="HardDisk" port="0" device="0">

<Image uuid="{c632affb-b497-4d70-846b-7eda09bfd81c}"/>

</AttachedDevice>

</StorageController>

</StorageControllers>

</Machine>

</VirtualBox>

comment:5 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Assertion fail in VBoxManage registervm command to Assertion fail in VBoxManage registervm command => fixed in 3.0.12

VirtualBox 3.0.12 (didn't check earlier versions) provides much better error messages. First error message I get is that the DVD image isn't available. No big surprise, and I "fixed" that by deleting the image reference in the xml file.

Second error message is "Error: Unregistered machine 'suse111-64' cannot have hard disks attached (found 1 hard disk attachments)". Which means that you're attempting to do what I suspected: register a VM config with attachments, which is documented as not supported. This restriction isn't there "just for fun", it is necessary due to how VirtualBox stores the hard disk information. This information is kept in VirtualBox.xml, and moving that around is nearly impossible.

So the error message bug is fixed, and VirtualBox behaves as designed and documented.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use