VirtualBox

Ticket #4846 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Virtualbox gets stuck with higher network load (Host Networking) (VERR_VMX_INVALID_VMCS_PTR guru)

Reported by: mkromer Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Machine Guest (Windows 2003 R2 x86) gets stuck with higher network load on host interface (intel server)

It happens sometimes with high load, not always.

VBox 3.0.4 with Guest Additions. Host is opensuse 11.1 x86_64.

Attachments

VBox.log Download (127.6 KB) - added by mkromer 5 years ago.
VirtualBox Log at crash time
VBox.2.log Download (110.7 KB) - added by mkromer 5 years ago.
crash again with only 1 CPU and 'high' network load (30m/bit steady) with hostonly interface
ara_vb.log Download (192.7 KB) - added by ARA 3 years ago.

Change History

Changed 5 years ago by mkromer

VirtualBox Log at crash time

comment:1 Changed 5 years ago by mkromer

I would like to correct ... I can reproduce problem also without a high load on the network...

The only thing I did after it was running stable for a long time: Installed Office 2003. Since that time its not possible anymore to keep that system alive for more than 5 minutes. Microsoft Update I don't even get as far as needed to select updates.

Happens also with VBoxHeadless

comment:2 Changed 5 years ago by mkromer

I can now tell what the problem was:

SMP. I had the machine running with 2 vCPU's. The System is a 4-Core i7 (with HT 8), setting the CPU down to one keeps the system running stable again. However the System *was* running stable before installing Office 2003, so this might be an issue to look at.

comment:3 Changed 5 years ago by mkromer

CPU of host

processor : 7 vendor_id : GenuineIntel cpu family : 6 model : 26 model name : Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz stepping : 4 cpu MHz : 1600.000 cache size : 8192 KB physical id : 0 siblings : 8 core id : 3 cpu cores : 4 apicid : 7 initial apicid : 7 fpu : yes fpu_exception : yes cpuid level : 11 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology tsc_reliable nonstop_tsc pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 lahf_lm ida tpr_shadow vnmi flexpriority ept vpid bogomips : 5345.96 clflush size : 64 cache_alignment : 64 address sizes : 36 bits physical, 48 bits virtual power management:

comment:4 Changed 5 years ago by sandervl73

  • Summary changed from Virtualbox gets stuck with higher network load (Host Networking) to Virtualbox gets stuck with higher network load (Host Networking) (VERR_VMX_INVALID_VMCS_PTR guru)

You aren't running other VM software (such as KVM) at the same time, are you?

comment:5 Changed 5 years ago by mkromer

No, of course not. in fact there isn't even anything installed that could collide (like kvm kernel module, xen, vmware)... host is a cleanly installed and updated opensuse 11.1 x64 with a newer kernel.

Linux borg 2.6.29.6-jen82-rt #1 SMP PREEMPT RT 2009-08-12 08:40:26 +0200 x86_64 x86_64 x86_64 GNU/Linux

Changed 5 years ago by mkromer

crash again with only 1 CPU and 'high' network load (30m/bit steady) with hostonly interface

comment:6 Changed 5 years ago by mkromer

So, it seems to be the same problem again, it just takes longer with only 1 CPU

comment:7 Changed 3 years ago by ARA

Found this issue and here is how it can be reproduced on FreeBSD 8.2 AMD64 host system. Following script should be launched to install virtualbox stuff on host machine:

#!/bin/tcsh

echo "Executing $0..."

if ($#argv != 1) then
    echo "Usage: $0 local_user_name"
    exit 1
endif

set -r local_user_name = $1
set -r this_path = `dirname $0`

# http://wiki.freebsd.org/VirtualBox
pkg_add -r virtualbox-ose

if (! -e /etc/rc.conf.virtualbox) then
    cp /etc/rc.conf /etc/rc.conf.virtualbox
    echo vboxnet_enable=\"YES\" >> /etc/rc.conf
endif

if (! -e /boot/loader.conf.virtualbox) then
    cp /boot/loader.conf /boot/loader.conf.virtualbox
    echo vboxdrv_load=\"YES\" >> /boot/loader.conf
endif

if (! -e /etc/devfs.conf.virtualbox) then
    cp /etc/devfs.conf /etc/devfs.conf.virtualbox
    echo perm cd0 0660 >> /etc/devfs.conf
    echo perm xpt0 0660 >> /etc/devfs.conf
    echo perm pass0 0660 >> /etc/devfs.conf
endif

pw groupmod vboxusers -m $local_user_name

exit 0

This will install virtualbox 3.2.12_OSE on host machine.

After that, create FreeBSD guest machine (64-bit) and set Network to "Bridged adapter", select from list host's machine's network interface (in my case - ale0). Install guest FreeBSD VM with minimal image, open sshd there and try to rsync some big data from host machine to guest - VB crashes with VERR_VMX_INVALID_VMCS_PTR guru when network load reaches some critical peak value (usually, in 5-10 seconds). However, limiting bandwidth using rsync cmd line option (--bwlimit) to say 10 (kb) allows to avoid this crash, 50 can work up to minute, 100 crashes in ~30 sec). Also crash never happens when data transfer happens between guest machine and "internet".

So in short - crash happen when "Bridged adapter" is set to ale0 and direct data transfer happens on high speed between host and guest machines.

There is a workaround - create and use "proper" bridge (for example, like described here -  http://bsdwiki.reedmedia.net/wiki/networking_qemu_virtual_bsd_systems.html). After that, when I select "bridge0" issue gone completely.

p.s. at least two other tickets may be the same issue - 4918 and 5962, just updated oldest one.

Changed 3 years ago by ARA

comment:8 Changed 3 years ago by ARA

In previous post - After that, when I select "bridge0" issue gone completely. must be After that, when I select "tap0" issue gone completely.

comment:9 Changed 3 years ago by aleksey

Does the problem appear with the latest versions of VirtualBox (4.0.12 and 4.1)?

comment:10 Changed 3 years ago by mkromer

Problem could not be reproduced with openSUSE 11.4 (x86_64) and Virtualbox 4.1 Packages.

comment:11 Changed 3 years ago by aleksey

  • Status changed from new to closed
  • Resolution set to fixed

Good to hear. I am resolving this one then.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use