VirtualBox

Ticket #4823 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Missing declaration of utf8_mbtowc function in utils.c

Reported by: mloskot Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Linux
Host type: other

Description

I use VirtualBox 2.2.4r47978 under Windows Vista Business (64-bit) with Linux Ubuntu 9.10 (64-bit) as guest OS. The guest system uses kernel 2.6.31.

I tried to build guest additions but compilation failed with the following error:

/home/mloskot/tmp/vbox/linux/module/vboxvfs/utils.c:423: error: implicit declaration of function utf8_mbtowc

I've managed to fix this problem by adding these two lines somewhere below line 30:

extern int utf8_mbtowc(wchar_t*, const __u8*, int);
extern int utf8_wctomb(__u8*, wchar_t, int);

I tried to fix it properly by including missing header file:

#include <linux/nls.h>

but it doesn't work. I did a quick research and it seems the NLS functions have been renamed in source code of recent kernel versions. Here is patch with  NLS: update handling of Unicode posted by Alan Stern on Thu Apr 30 2009.

Hopefully, VirtualBox could be updated to follow the kernel changes.

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by mloskot

It's been a while since I submitted this report and I'm wondering if there would be any chance for any reaction to this report? Confirmation of the problem or rejection as invalid?

comment:2 in reply to: ↑ 1 Changed 4 years ago by lzm

I had the same problem with VirtualBox 2.2.4r47978 running Ubuntu Netbook Remix 9.10.

The problem is solved in VirtualBox 3.0.8.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use