VirtualBox

Ticket #4798 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

garbled video in linux guest after upgrade to 3.0.4 -> duplicate of #4430

Reported by: dlannom Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host: Centos 5.3 Guest: Fedora 10 and Fedora 11

Video was working in 2.2.4, after upgrading to 3.0.4 and installing guest additions, video became garbled, with the size of the screen compressed along the vertical axis.

Problem was resolved when the option "Auto resize guest display" was selected

Attachments

fedora-11-2009-08-17-17-39-15.log Download (100.4 KB) - added by dlannom 5 years ago.
logfile from fedora 11
xorg.conf Download (856 bytes) - added by jeffhoff 5 years ago.
xorg.conf that seems to work..

Change History

Changed 5 years ago by dlannom

logfile from fedora 11

comment:1 Changed 5 years ago by dlannom

it some times takes several selections of "Auto resize guest display" until it works

comment:2 Changed 5 years ago by leonid

Is it related to 3d? Doesn't it happen without 3d enabled for the VM?

comment:3 Changed 5 years ago by dlannom

The problem occurs even with 3d box unchecked. But it may be slightly less likely to occur. [5 starts with 3d enabled = 4 with problem

2 starts without 3d enabled = 1 with problem

]

comment:4 Changed 5 years ago by dlannom

The error almost always occurs when I start with 3d enabled. Frequently does not occur without 3d enabled

Sometime with 3d I've seen kernel panics like:  http://www.kerneloops.org/submitresult.php?number=648826

comment:5 Changed 5 years ago by dschaefer

I get the same problem consistently with the latest upgrade of Fedora 11 and vbox 3.0.4. And the workaround doesn't help me.

Seems to be something between the virtual box video driver and the kernel upgrade that happened when I did the recent yum upgrade.

comment:6 Changed 5 years ago by dschaefer

Oh wait, the workaround helps but only after I log in. Anyway, this should be easy to reproduce. Install Fedora 11 and do a yum upgrade to the latest, install vbox additions.

comment:7 Changed 5 years ago by jeffhoff

Try the attached xorg.conf file...

Seems vboxvideo driver is not quite prime time.

Changed 5 years ago by jeffhoff

xorg.conf that seems to work..

comment:8 Changed 5 years ago by dlannom

Vesa driver does work, but does not support 1920x1200 screen

comment:9 Changed 5 years ago by michael

You might want to try this test build of the 3.0.5 Guest Additions (see  here for information and warnings about test builds):

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r50791.iso

This contains a fix for the issue, and most people (all but one) who tried it confirmed that it worked for them.

comment:10 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from garbled video in linux guest after upgrade to 3.0.4 to garbled video in linux guest after upgrade to 3.0.4 -> duplicate of #4430

Actually, this is a duplicate of ticket #4430.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use