VirtualBox

Ticket #4790 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Hostonly networking has several problems (and is basically not working yet) => Fixed in SVN/3.0.6

Reported by: jenisys Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.0.4 Keywords: GUI and basic config
Cc: Guest type: Linux
Host type: Mac OS X

Description

The manual states the VirtualBox 3.0.4 supports only vboxnet0 on non-Windows hosts. But even that is not working.

PROBLEMS:

  1. GUI allows you seldom to configure and use a hostonly network adapter The best case seems to occur when the HostOS was just rebooted. Most of the the time Virtual Machine Settings mark the network adapter as invalid.
  1. Using vboxmanage to configure and assign the hostonly configuration works, but it fails when the Virtual Machine should be started. VirtualBox complains when an hostonly adapter is used and fails to start it.

  1. GUI ALZHEIMER: Hostonly networks are forgotten in the GUI (sort-of). Every time you open up VirtualBox > Preferences > Network dialog, the list of networks is empty even if some are configured in VirtualBox.xml. This happens especially if you start VirtualBox for the second time (but the old VirtualBox services have already stopped). It can also be verified that the VirtualBox.xml data is retrieved. When you recreate vboxnetX, the corresponding DhcpServer information is made available in the configuration dialog of the network.

NOTES: The host-specific network adapter seems to be created correctly. If I check the configuration w/ 'ifconfig', it has the correctly assigned IP address and netmask. The same is true for additional hostonly adapters, like vboxnet1, vboxnet2 ... But as long as I cannot really use it (for starting the Virtual Machine and communicating over it), this feature is broken as far as I am concerned.

Attachments

VirtualBox.xml Download (3.5 KB) - added by jenisys 5 years ago.
VirtualBox config file
alice.xml Download (5.4 KB) - added by jenisys 5 years ago.
Config file of Virtual Machine.

Change History

comment:1 Changed 5 years ago by aleksey

With 3.0.4 release version I cannot reproduce neither of the symptoms you have described:

  1. In VM settings I can select any of vboxnetX adapters I've created in VirtualBox > Preferences > Network. By the way, vboxnet0 is created automatically as soon as you load VBoxNetAdp.ko module (it happens during host startup), so you should always be able to choose vboxnet0 unless you've explicitly deleted it in network preferences dialog.
  1. No problem with starting/using vboxnetX interfaces.
  1. Host-only adapters are indeed forgotten, but only when you unload/reload VBoxNetAdp.ko (or reboot the host), while their configuration parameters are preserved in VirtualBox.xml. This problem will be fixed in future versions of VirtualBox.

Could you attach your VirtualBox.xml and configuration xml file of VM you used for testing?

Changed 5 years ago by jenisys

VirtualBox config file

Changed 5 years ago by jenisys

Config file of Virtual Machine.

comment:2 Changed 5 years ago by jenisys

VirtualBox config files attached. I hope that helps.

comment:3 Changed 5 years ago by sjbufton

This is probably the same as bug #4698 - host-only networking does not work without a physical network connection.

comment:4 Changed 5 years ago by frank

  • Summary changed from Hostonly networking has several problems (and is basically not working yet) to Hostonly networking has several problems (and is basically not working yet) => Fixed in SVN/3.0.6

comment:5 Changed 5 years ago by aleksey

  • Status changed from new to closed
  • Resolution set to duplicate

comment:6 Changed 5 years ago by aleksey

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:7 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use