VirtualBox

Ticket #4787 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Settings: Disabled WLAN causes invalid network configuration

Reported by: jenisys Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.0.4 Keywords: Settings: network
Cc: Guest type: Linux
Host type: Mac OS X

Description

HOST-OS: MACOSX 10.5.8 (GUEST-OS: Ubuntu 9.04)

VirtualBox has a problem with a disabled WLAN interface and using the Settings dialog for a Virtual Appliance related to Network configuration.

EFFECTS:

  • Cause VirtualBox FATAL-ERROR on start, if WLAN enabled during Settings, but later disabled when Appliance is started.
  • Prevents me from using vmnet1, vmnet8 (while WLAN is disabled at configuration time)

DETAILLED DESCRIPTION: I normally disable the WLAN network interface on my MacBook (or have a network configuration profile without it). When I try to configure the Network Setting of an Virtual-Appliance in this state by selecting a Bridged Adapter, an error appears in the the status line "invalid configuration detected". Therefore, the OK button is disabled.

When I enable my WLAN network interface and open the Setting again, I can select the Name with "en1: AirPort" and leave the dialog with OK. In addition, I can now also select vmnet1, vmnet8 for other network interfaces. NEXT STEP: I disabled the WLAN interface again. And start the Virtual-Appliance. OOPS, it fails with an VirtualBox error (just after the start).

ADDITIONAL NOTES: A disabled WLAN interface prevents me from using vmnet1 and vmnet8 in Settings. They are never shown. When I enable the WLAN interface, I can easily assign them to other Network Adapters (in Brdiged Adpater mode). When the WLAN interface is disabled, this configuration seems to be lost.

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4698 and fixed after VBox 3.0.6 Beta 1.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use