VirtualBox

Ticket #4779 (closed defect: obsolete)

Opened 7 years ago

Last modified 6 months ago

No mouse control in 3D applications with Guest Additions installed -> obsolete

Reported by: skscrivano Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

No mouse cursor control in 3D applications such as games has been observed after installing the Virtual Box additions in KUBUNTU. To verify the cause of this problem, KUBUNTU was installed in a Windows Vista Host. In the first test, a game was run without the guest additions by loading "Planet Penquin Racer". No problem with cursor mouse control was observed. In the second test, the guest additions were installed in KUBUNTU and the system was restarted. The game was then loaded again, and mouse control in the game had ceased with observation of a frozen and disappearing mouse pointer in the top left hand corner of the screen. Other 3D games have been tested with no mouse control. Defining the "InputDevice" mouse Identifier and options in /etc/X11/xorg.conf did not solve the problem. /etc/X11/xorg.conf has nothing but the minimal default settings even after the guest additions are installed. There are no virtual box configurations present in xorg.conf and editing the file to include them does not change the mouse problem.

Change History

comment:1 Changed 7 years ago by michael

This may be related to #4713.

comment:2 Changed 7 years ago by michael

Reproducible here, but since I will be away for a week I can't look at it any more just now.

comment:3 Changed 7 years ago by michael

Note: this is probably not the same as #4713, as the problem goes away when the game is exited. It might be worth contacting the game developers to see if they have an idea as to what might be going wrong. It may help them to know that the VirtualBox mouse integration acts like an absolute pointing device (e.g. a graphics tablet).

comment:4 Changed 6 months ago by michael

  • Status changed from new to closed
  • Resolution set to obsolete
  • Summary changed from No mouse control in 3D applications with Guest Additions installed to No mouse control in 3D applications with Guest Additions installed -> obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use