VirtualBox

Opened 15 years ago

Closed 6 years ago

#4772 closed defect (wontfix)

Can't type parentheses in Windows XP guest running on Ubuntu 9.04 host accessed over VNC -> VNC not officially supported

Reported by: SirX Owned by:
Component: other Version: VirtualBox 3.0.4
Keywords: parentheses, keyboard Cc:
Guest type: Windows Host type: Linux

Description (last modified by Michael Thayer)

I am running VirtualBox 3.0.4 on Ubuntu 9.04 with a Windows XP guest OS. If I make a VNC connection into my Ubuntu host, I cannot type parentheses (left or right) into the Windows guest OS. There is no response to the key press. No other keys are affected, as far as I can tell. I can type parentheses into the host over VNC, into the guest if I am sitting at the computer, or into the guest if I use RDP instead of VNC. This is sufficiently obscure that I have only found one other report of this problem: http://www.ale.org/pipermail/ale/2009-July/111969.html

Attachments (2)

WinXP-2010-04-27-13-51-09.log (35.9 KB ) - added by Ben Armstrong 14 years ago.
The requested log of WinXP guest OS
x11vnc.log (2.1 KB ) - added by Ben Armstrong 13 years ago.
Excerpt from x11vnc -xkb output when pressing left and right paren keys.

Download all attachments as: .zip

Change History (16)

comment:1 by Michael Thayer, 15 years ago

Could you please attach a log file from a run of the VM? Thanks.

comment:2 by Frank Mehnert, 14 years ago

Resolution: invalid
Status: newclosed

No response, closing.

by Ben Armstrong, 14 years ago

The requested log of WinXP guest OS

comment:3 by Ben Armstrong, 14 years ago

Resolution: invalid
Status: closedreopened

Reproduced on:

  • a Debian "squeeze" system acting as host, using virtualbox-ose 3.1.6-dfsg-2 and x11vnc 0.9.9-1 as the VNC server; also failed with virtualbox-ose 3.1.2, which i subsequently upgraded;
  • running a Win XP guest OS;
  • and using a Debian "sid" system as the VNC client host, using xvnc4viewer 4.1.1+X4.3.0-37 and also an Ubuntu host (version unknown) again using xvnc4viewer (version unknown).

Note: x11vnc needs to be started with "x11vnc -xkb" or else other keys may not be mapped properly (a problem not limited to virtualbox).

Just as the original submitter reported, parentheses do not work in the virtualbox guest OS when run in VNC. They do, however, work in other applications running in the same VNC session. Also, they work in virtualbox when I have direct (non-VNC) access to my desktop.

I would be happy to provide any other info you need. I have attached the requested WinXP guest OS log.

Thanks, Ben

comment:4 by Ben Armstrong, 13 years ago

The problem is reproducible using:

virtualbox 3.2.12-12-dfsg-1
x11vnc 0.9.10-1.1

I'm still seeking a solution. Is there anything else I could provide to help debug the issue?

Thanks,
Ben

in reply to:  4 comment:5 by Ben Armstrong, 13 years ago

Replying to BArmstrong:

virtualbox 3.2.12-12-dfsg-1

Sorry, typo. That should be:

virtualbox 3.2.12-dfsg-1

comment:6 by Michael Thayer, 13 years ago

Have you tried this on VirtualBox 4.0? This release contains some fixes related to keyboard handling on X11 hosts.

in reply to:  6 comment:7 by Ben Armstrong, 13 years ago

Replying to michael:

Have you tried this on VirtualBox 4.0? This release contains some fixes related to keyboard handling on X11 hosts.

Just tried it now with 4.0.2 for Squeeze. The problem is not solved in that version, even after upgrading to latest Guest Additions.

by Ben Armstrong, 13 years ago

Attachment: x11vnc.log added

Excerpt from x11vnc -xkb output when pressing left and right paren keys.

comment:8 by Ben Armstrong, 13 years ago

If I use "x11vnc -xkb -debug_keyboard" and press left and right parens in a text editor, this output is produced (see attachment x11vnc.log). Taking the "found more than one keycode" messages as a clue, I guessed this workaround might do the trick:

$ x11vnc -xkb -skip_keycodes 187,188

It worked! Pressing paren keys now produces output in the editor.

So, shouldn't the VirtualBox keyboard driver be handling these keycodes as well (or the keysyms mapped to these keycodes)? I don't know if the VNC server solutions commonly used by other users (vino, etc.) are flexible enough to use this workaround, and certainly it takes a bit of digging to find and apply it, so some "just works" solution would be far preferable.

comment:9 by Ciaran, 13 years ago

I have the same issue, but using vino-server, for which there doesn't seem to be an equivalent workaround. (Host is 10.04 in this case)

comment:10 by John Pye, 13 years ago

I have the same issue. I am using VirtualBox 4.0.4 on Ubuntu 10.04. I am using the PPA packages by user 'debfx'.

The problem occurs when I view my remote host machine via xtightvncviewer over a tunnelled SSH connection, when I have VirtualBox-OSE running in a window on the host. I can't sent parentheses ( ) to the guest operating system (Windows 7 in my case).

The problem disappears when I add port forwarding to a TightVNC server installed on the guest OS, and then connect to the guest TightVNC server (via a tunnelled SSH connection to the host and the forwarded port to the guest).

comment:11 by Fuquay, 9 years ago

Still have this issue using VirtualBox 4.3.18 and x11vnc 0.9.13 running on Ubuntu 14.10.

As a workaround, I can confirm that adding the arguments -xkb -skip_keycodes 187,188 to x11vnc allows parentheses to be typed into the virtual machine.

comment:12 by David Biesack, 6 years ago

As an additional data point: I have this problem as well, although I'm running VirtualBox 5.1.21 on a CentOS 7.3 host, Windows 10 guest. This happens with either the native VNC client on Mac OS X, or with the commercial Jump Desktop client on Mac OS X. CentOS comes with vino-server

comment:13 by Michael Thayer, 6 years ago

Description: modified (diff)

I'm afraid to say that we were discussing use of VirtualBox over VNC last week and decided that we can not afford to officially support it, precisely because keyboard over VNC is so hard to get working. PC virtualisation places higher requirements on keyboard support than most applications, which VNC servers generally do not handle in a way which is usable for us. It might be worth talking to the Vino developers to see what they think. If you do, I wrote up a bit of information on the wiki<1> a bit of information about VirtualBox keyboard handling which should help them to understand what is happening.

<1> https://www.virtualbox.org/wiki/X11Keyboard

The easiest solution might be for Vino to optionally send key codes matching those that X.Org uses. For this it would probably need to be told what layout was in use on the remote system. If the developers feel really adventurous, they can look at our legacy keyboard code which can detect the layout in use, though it is sadly not capable enough to detect it though a VNC connection.

comment:14 by Michael Thayer, 6 years ago

Resolution: wontfix
Status: reopenedclosed
Summary: Can't type parentheses in Windows XP guest running on Ubuntu 9.04 host accessed over VNC.Can't type parentheses in Windows XP guest running on Ubuntu 9.04 host accessed over VNC -> VNC not officially supported

For now I will have to close this as "won't fix" though.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use